Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

forrtl: severe (174): SIGSEGV, segmentation fault occurred when run wrf.exe

eloim_www

New member
Dear,
When I running wrf.exe,this error has happened.I use WRF4.5 and use the CGLC-MODIS-LCZ dataset.I can successfully run wrf.exe with sf_urban_physics=2 or 3, but when I use the slucm scheme, this error happend. This is my rsl.* file. I have already use 'grep "cfl" rsl.*' to check if there has something wrong.
Thanks for your help.
 

Attachments

  • namelist.input
    3.9 KB · Views: 14
  • rsl.out.0000
    1.1 MB · Views: 9
  • rsl.error.0000
    1.1 MB · Views: 16
Did you build WRF with intel compiler? I once faced similar (not sure exactly same) error messages.

It worked after setting environment variable of stack size bigger, for my case.

"setenv MP_STACK_SIZE 64000000"
(you might want to find it in WRF user's guide documentation for full description)

You can find useful comments dealing with this issue in this link:
 
@eloim_www
The issue is likely that you're using too many processors for the size of your domain. Take a look at this FAQ that discusses how to determine a reasonable number of processors, based on your domain sizes. Additionally, unless you're just trying to learn how to use WRF, your domains should be no smaller than 100x100. Otherwise large scale features do not have time to be processed in the time it takes for them to move in/out of the domain. You may want to reference this best practices page that has suggestions for the domain settings. If none of that is helpful, please package all of your rsl* files together in a single *.tar file and attach that, along with your modified namelist.input file, for us to take a look. Thanks!
 
Did you build WRF with intel compiler? I once faced similar (not sure exactly same) error messages.

It worked after setting environment variable of stack size bigger, for my case.

"setenv MP_STACK_SIZE 64000000"
(you might want to find it in WRF user's guide documentation for full description)

You can find useful comments dealing with this issue in this link:
Thank you, I will try
 
@eloim_www
The issue is likely that you're using too many processors for the size of your domain. Take a look at this FAQ that discusses how to determine a reasonable number of processors, based on your domain sizes. Additionally, unless you're just trying to learn how to use WRF, your domains should be no smaller than 100x100. Otherwise large scale features do not have time to be processed in the time it takes for them to move in/out of the domain. You may want to reference this best practices page that has suggestions for the domain settings. If none of that is helpful, please package all of your rsl* files together in a single *.tar file and attach that, along with your modified namelist.input file, for us to take a look. Thanks!
I try to reduce my processors to run my case but it crash witn the same way. Here are my rsl* files and namelist.input.
 

Attachments

  • namelist.input
    3.9 KB · Views: 3
  • rsl.tar
    4.6 MB · Views: 2
@eloim_www
The issue is likely that you're using too many processors for the size of your domain. Take a look at this FAQ that discusses how to determine a reasonable number of processors, based on your domain sizes. Additionally, unless you're just trying to learn how to use WRF, your domains should be no smaller than 100x100. Otherwise large scale features do not have time to be processed in the time it takes for them to move in/out of the domain. You may want to reference this best practices page that has suggestions for the domain settings. If none of that is helpful, please package all of your rsl* files together in a single *.tar file and attach that, along with your modified namelist.input file, for us to take a look. Thanks!
I also try to enlarge my domain, and this error happened again.
 

Attachments

  • namelist.input
    4 KB · Views: 4
  • wrf_rsl.tar
    1.8 MB · Views: 3
@eloim_www
Thanks for sending that information. I've created a case using your namelist.input and I am able to replicate the issue you see - it works with urban_physics options 2 and 3, but not with option 1. I am not a physics expert, so I've reached out to a couple of my physics colleagues to ask if there is a limitation to using this option with urban_physics=1, and if not, whether they have any suggestions. I'll keep you posted. Thank you for your patience.
 
Hi,
Can you try setting the following in the &domains section of the namelist, and see if it makes any difference?

Code:
 force_sfc_in_vinterp                = 3
 interp_type                         = 1
 lagrange_order                      = 1

You will need to re-run real.exe after setting those, and then run wrf.exe.
 
Hi,
Can you try setting the following in the &domains section of the namelist, and see if it makes any difference?

Code:
 force_sfc_in_vinterp                = 3
 interp_type                         = 1
 lagrange_order                      = 1

You will need to re-run real.exe after setting those, and then run wrf.exe.
Thanks for your reply, I had tried to add in the &domains section, but wrf.exe crashed again. I run wrf on my school's HPC platform, so I think it's the computer problem, I decided to use the BEP and BEM scheme.
 
Thanks for your reply, I had tried to add in the &domains section, but wrf.exe crashed again. I run wrf on my school's HPC platform, so I think it's the computer problem, I decided to use the BEP and BEM scheme.
Hi! I wonder if you have ever tried the SLUCM with the LCZ data after your last post? I have tried to use BEP with LCZ and the wrf run well. However, when using SLUCM, the wrf crashed soon at the first time step.
 
Top