Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

frames_per_wrfbdy file limit, NDOWN.EXE

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am running ndown.exe to get the BCs from domain 01 to domain 02, for a 12 hour period, for every second. I have wrfout_d01 files for every hour with 3600 frames in them for every second. I would like to create wrfbdy_d02 for the whole 12 hour period. I have been running ndown successfully without any errors. It goes smoothly over the whole 12 hour period. However, when I check the wrfbdy_d02 it only contains the first 10000 seconds. I started ndown again from 3 hours later, however, again wrfbdy_d02 only contains the first 10000 time steps. Is there any way I can increase this limit? is this hardcoded or is there any variable that I need to set up in my namelist?

Hi Mahdad,

Take a look in the file WRF/external/io_netcdf/wrf_io.F90. Near the top of the file, you should see:
integer parameter :: MaxTimes = 10000

You can increase that value, and then you'll need to recompile the code to incorporate the change. This should allow you to have more frames in your files.