Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

geogrid.exe not running

Masud_Rana

New member
Hi everybody,
I am new to use the WRF. I compiled installing WRF 4.5 and WPS 4.5 successfully in ubuntu 22.04 and gfortran 11.4.
Now when I am trying to run the geogrid.exe, it returns error message like, "./geogrid.exe: undefined symbol: nc_inq_var_quantize". Can you anybody please help me find the problem? My namelist file is attached here.

Thanks
Masud
 

Attachments

  • namelist.wps
    650 bytes · Views: 1
Hi Masud,
Typically an error like this means that perhaps the netCDF library (or version) has been changed/updated since you originally built WPS. If you had to load specific versions, or if you had to set paths before building WPS, and then you logged out of your terminal, you will no longer have those settings when you log back in (unless you have them permanently set in an environment script - e.g., .bashrc).
 
Hi Masud,
Typically an error like this means that perhaps the netCDF library (or version) has been changed/updated since you originally built WPS. If you had to load specific versions, or if you had to set paths before building WPS, and then you logged out of your terminal, you will no longer have those settings when you log back in (unless you have them permanently set in an environment script - e.g., .bashrc).
Thank you dear. After setting the environment permanently I have been able to run the geogrid program.
 
Top