Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Geogrid Segmentation Fault

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am facing this error when tried to run Geogrid for the first time after compiling it.
Would really appreciate any help with this. Thanks WRF team.

Processing domain 1 of 1
Processing XLAT and XLONG

Program received signal SIGSEGV: Segmentation fault - inavlid memory reference.

Backtrace for this error:

0x7F497F7E in ext_ncd_inquiry
0x43216A in_output_module_MOD_output_init
0x43B3E5 in_process_tile_module_MOD_process_tile
Segmentation fault


  • namelist.wps
    1.2 KB · Views: 64
  • geogrid.log
    9.2 KB · Views: 66
Your namelist.wps looks fine. I am suspicious this is a memory issue.
If you are using Linux, check to see if there is any restriction on your memory use:
ulimit -a
If the memory is limited, you may need to increase it with "ulimit -m value" (value in kbytes or mbytes)

Please also consult your computer manager how to increase memory in your machine.

Approximately how much memory is required? My HPC's interactive node has 8G. I am trying to run geogrid for North Norway.
The required memory depends on your grid numbers. It is not output in the log file, so I don't know exactly how large it is.
Hi there,

I am new to the model. It seemed that I ran into the same exact error when running ./geogrid.exe for a test case.

Here is the output of "ulimit -a":
[dienwu@login2 WPSV4]$ ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 768207
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 4096
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

The machine has 188 GB memory in total, so I suppose memory should not be an issue?
Any suggestion is much appreciated. Here are my geogrid.log and namelist.wps.


  • namelist.wps
    1.3 KB · Views: 43
  • geogrid.log
    9.5 KB · Views: 50
This is not a memory issue. Instead, I found the following error message in your georgic.log file:

Could not read 'index' file /central/home/dienwu/WRF/WPSV4/geog/NUDAPT44_1km/index for field URB_PARAM
Could not read 'index' file /central/home/dienwu/WRF/WPSV4/geog/urbfrac_nlcd2011/index for field FRC_URB2D
Could not read 'index' file /central/home/dienwu/WRF/WPSV4/geog/nlcd2011_imp_ll_9s/index for field IMPERV

Please double check your wps_static data and make sure all required files are available. If not, The data can be downloaded from