Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ideal: error opening wrfinput for writing -1021


Dear team,
I try to test the ideal cases WRF4.5 and when I start ./ideal.exe I get the following messages:
taskid: 0 hostname: kornog
starting wrf task 0 of 1
module_io_quilt_old.F 2931 F
Quilting with 1 groups of 0 I/O tasks.
Ntasks in X 1 , ntasks in Y 1
No git found or not a git repository, git commit version not available.
Domain # 1: dx = 1000.000 m
Parent domain
ids,ide,jds,jde 1 101 1 101
ims,ime,jms,jme -4 106 -4 106
ips,ipe,jps,jpe 1 101 1 101
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 301323708 bytes allocated
-------------- FATAL CALLED ---------------
ideal: error opening wrfinput for writing -1021

I tried all the ideal cases available none is working. Also a real case ended with:
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 665308900 bytes allocated
-------------- FATAL CALLED ---------------
error opening for input; bad date in namelist or file not in directory

which was wrong as the file is available and not corrupted.

I attach a few files that may be interesting. They are related to the case em_quarter_ss
Many thanks for your help. I would like to have it worked after more than one week trying to compile :-(

ps: if you answer, please consider that I am not very "good" at programming and be as precise as possible. I am working on linux (ubuntu).


  • rsl.out.0000
    73.6 KB · Views: 2
  • rsl.error.0000
    1.2 KB · Views: 1
  • ideal.log
    399 bytes · Views: 1
  • namelist.input
    4.7 KB · Views: 0
  • configure.wps
    3.4 KB · Views: 0
Thanks for your answer. I tried all and got the same message. But specifically it was here the em_wave. I have no idea. I tried to delete some big files, remake the path etc. Nothing works
I would be grateful if somebody could help me here as I can work on it any further. Is it a problem with my computer? thanks for your help best
To run WRF ideal cases, please follow the steps below:

(1) in top WRF directory, type ./clean -a, then ./configure and ./compile em_b_wave

(2) enter the directory WRF/test/em_b_wave, then type ./ideal.exe to create initial condition

(3) type ./wrf.exe to run the ideal case.

For more details, please see Chapter 4: WRF Initialization
Unfortunately, this is exactly what I did. i reainstalled everything, made the check etc and downgraded to a lower version of netcdf (still 4) and WRF (4). Unfortunately, it still does not compile and I don't know why. I get the following error
f951: Warning: Nonexistent include directory ‘/home/kermarrec/kermarrec/tmp/WMF/Build_WRF/LIBRARIES/netcdf/include’ [-Wmissing-include-dirs]

326 | USE module_sf_clm
| 1
Fatal Error: Cannot open module file ‘module_sf_clm.mod’ for reading at (1): No such file or directory
compilation terminated.


  • build.log
    678.5 KB · Views: 0
  • configure.txt
    20.8 KB · Views: 0
Last edited: