Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

intel compiler: real.exe runtime error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear wrfhelp,

I have been using wrf since 2011, able to solve compiling and run time errors but this time it looks like more complicated. I'm tryng to compare performance between gfortran-10&gcc-10 and intel's compilers ifort&icc for WRF-4.2 version, I prepared two different building of all the required software (netcdf, jasper, mpi ...etc) for the two different compilers with no errors and little warning. Geogrid&ungrib&metegrid steps goes smooth with both compiler. While gfortran&gcc executables work fine also with real.exe and wrf.exe, intel compilation ./real.exe does not.
I run real.exe generated by gnu complilers with met_em_d0* file obtained from intel compilers and the process goes perfectly. At the same time i run intel's real.exe with the met_em _d0* generated by GNU execurables obtaining always the same error, I can guess that the problems lies in the intel real.exe executable. Same error turn up with ERA5 and gfs.t*z.*pgrb2f* using the unaltered Vtable suppied by wps, also with no nest, debug compilation, and standard "CONUS" parameterization suggested in the default namelist.input.
I attached the complete namelist, ./real.exe > output (it semms that in serial and -g mode rsl.*are not generated) and configure.wrf. Here is the "highlight" of the error.
I hope I supplied all the necessary info to solve the problem, or at least for a hint.

I would like to thank you in advance for attention.

In serial and debug configuraton I'm receiving this error:

Ntasks in X 1 , ntasks in Y 1
Configuring physics suite 'conus'

mp_physics: 8 8 8
cu_physics: 6 6 0*
ra_lw_physics: 4 4 4
ra_sw_physics: 4 4 4
bl_pbl_physics: 2 2 2
sf_sfclay_physics: 2 2 2
sf_surface_physics: 2 2 2

(* = option overrides suite setting)
Domain # 1: dx = 9000.000 m
Domain # 2: dx = 3000.000 m
Domain # 3: dx = 1000.000 m
Parent domain
ids,ide,jds,jde 1 250 1 300
ims,ime,jms,jme -4 255 -4 305
ips,ipe,jps,jpe 1 250 1 300
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 2803404768 bytes allocated
Time period # 1 to process = 2010-07-15_00:00:00.
Time period # 2 to process = 2010-07-15_01:00:00.
Time period # 3 to process = 2010-07-15_02:00:00.
Time period # 4 to process = 2010-07-15_03:00:00.
Time period # 5 to process = 2010-07-15_04:00:00.
Time period # 6 to process = 2010-07-15_05:00:00.
Time period # 7 to process = 2010-07-15_06:00:00.
Time period # 8 to process = 2010-07-15_07:00:00.
Total analysis times to input = 8.


Domain 1: Current date being processed: 2010-07-15_00:00:00.0000, which is loop # 1 out of 8
configflags%julyr, %julday, %gmt: 2010 196 0.0000000E+00
d01 2010-07-15_00:00:00 Yes, this special data is acceptable to use: OUTPUT FROM METGRID V4.2
d01 2010-07-15_00:00:00 Input data is acceptable to use:
metgrid input_wrf.F first_date_input = 2010-07-15_00:00:00
metgrid input_wrf.F first_date_nml = 2010-07-15_00:00:00
d01 2010-07-15_00:00:00 Timing for input 1 s.
d01 2010-07-15_00:00:00 flag_soil_layers read from met_em file is 1
Max map factor in domain 1 = 1.02. Scale the dt in the model accordingly.
Using sfcprs to compute psfc
using new automatic levels program
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
real.exe 00000000036D898A Unknown Unknown Unknown
libpthread-2.27.s 00007F44003568A0 Unknown Unknown Unknown
real.exe 00000000004B1936 module_initialize 5170 module_initialize_real.f90
real.exe 00000000004585EF module_initialize 1638 module_initialize_real.f90
real.exe 0000000000438CB3 module_initialize 53 module_initialize_real.f90
real.exe 00000000004170E3 med_sidata_input_ 464 real_em.f90
real.exe 0000000000415A5B MAIN__ 242 real_em.f90
real.exe 0000000000414C82 Unknown Unknown Unknown 00007F43FFD70B97 __libc_start_main Unknown Unknown
real.exe 0000000000414B6A Unknown Unknown Unknown


    11.5 KB · Views: 49
    25.6 KB · Views: 48
  • namelist.input
    4.4 KB · Views: 58
  • output_real.exe.txt
    131.5 KB · Views: 54
  • configure.wrf
    25.7 KB · Views: 52
I don't see anything wrong in your namelist.options. All other files also look fine.
I am suspicious that this is related to insufficient memory. Codes built by intel usually requires larger memory.
Let's try to run over a single domain first. Please let me know If it still doesn't work.
If the single domain run is done successfully, please move on to run over nested domains with more number of processors. The following commands may also help:

1. If you are using csh or tcsh, try this: limit stacksize unlimited
2. If you are using sh or bash, use this command: ulimit -s unlimited
A small grain of sand in the gear, now it works!
I put the "ulimit -s unlimited" command on the bashrc file, but something did work well, now it's perfect.
Thanks so much