Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Interpolation issues in 3d Vars using ndown for wrfinput

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
For past several days, I am struggling with a very strange problem while using down. I am following the steps mentioned on the WRF Tutorial for running ndown.exe from a 15km domain to 3km domain (
So, the steps i follow is that I rename the wrfinput_d02 to wrfndi_d02, and make the required changes in namelist.input (please see it attached herewith). However, when I inspect U and V in the resulting wrfinput_d02, I see mostly close to zero values. Strangely enough, U10 and V10 seem reasonable. I have attached relevant ncview screenshots herewith. I have checked the wrfout_d01 files and the input wrfndi_d02 files, where U and V seem reasonable.
I am using WRF version 4.2.2.
I am a new user of WRF and there might be something fundamentally wrong. S far i have already tried different options of interpolation (liner or logarithmic), choices of eta levels. Any leads will be highly appreciated.

Best regards,


  • U_wrfndi_d02.PNG
    176.3 KB · Views: 885
  • U_wrfinput_d02.PNG
    27 KB · Views: 885
  • U_wrfout_d01.PNG
    125.2 KB · Views: 885
  • namelist.input_ndown.txt
    8.6 KB · Views: 44
I just ran a very simple test of ndown in V4.2.2 just to verify that it works okay and it does. I did not use your namelist, though. Can you send me the namelist you used for running d01 for wrf?

1) In the screenshot you attached for U for wrfout_d01 - is this for the initial d01 run, or for the final one (meaning it's actually d02)?

2) Will you actually need to use the ndown program? It's typically used when you have run for a long time (years) for a single domain, and then you later decide you want to run a nested domain, but don't want to have to re-run everything. Your run is only 5 days long, so just making sure this is necessary.
Thanks a lot for your kind reply and for making the test for me. It is great to know that down woks as expected for your set-up. I have attached the namelist that I used for running d01 for WRF. Please note that this namelist.input also includes chemistry specific settings. For running ndown, i was trying different ways (e.g. with our without chemistry; but the behaviour was similar).
Concerning your questions:
1. The screenshot I attached is for the initial d01 run. WRF crashes with segmentation fault if I proceed with the input files created using ndown. I assume it is because of the strange U and V values of wind.
2. I am a new user of WRF, but I feel I'll need ndown. Probably, you could suggest an alternative approach for nesting. I plan to simulate for 3 domains ( 2 nests). Currently, I am only testing my set up with ~10 days of run. Once tested, I plan to simulate for 1-year at least. If I run 2 way nesting (or even 1 way nesting without ndown), the number of processors I can use is limited by my coarser domain (1 per 10 grid points in x and y direction). Since my d02 and d03 domains have a larger number of grid points as compared to d01, I can dedicate more processors for those runs, if I run them separately using ndown. Probably I can gain some speed in simulation that way.

PS- One correction. In my original question, the caption of the second figure should be - "U in the resulting wrfinput_d02 (please see color scale)"

Best regards and thanks again for your help,


  • namelist.input_d01.txt
    8.5 KB · Views: 43
Thank you for sending that. Yes, it does sound like ndown will be necessary for your future runs. I noticed several wrf-chem settings in your original namelist. Are you running wrf-chem? If so, I would like to refer you to the wrf-chem section of the forum to post this. Their system runs a bit differently and there may be things necessary for chemistry that I'm not aware of - or perhaps they've seen a similar problem. If you're not using wrf-chem, please let me know and I'll continue to try to figure out what's going on.
Thanks a lot for the reply. yes, I was working with WRF-Chem.
I did further investigations to find the cause of the problem.
The problem seems to originate from WRF itself. I have identified the issue, but still do not understand it.
In my namelist, I also enabled hourly output of specific variables through auxhist1 in the following line

iofields_filename        = "my_file_d01.txt", "my_file_d02.txt",

If is comment out this line while running ndown, I get the expected values.

Best regards,
I'm very glad to hear that you were able to figure out the problem. Thank you for sharing that. That is not something that you need in the namelist during ndown.exe; however, it's puzzling why it would cause the problem. I'll put this on my list of things to track down in the code. I appreciate your work to find it!