Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Issue with Surface_Input_Source

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi everyone,

I've been trying to run WRF with changed boundary conditions by editing the met_em files (specifically, soil moisture). I saw that real.exe overwrites these changes if I do not set surface_input_source = 3 in the namelist.input file. However, when I do edit this and run real.exe, I get the error "mismatch_landmask_ivgtyp."

I read that this error was common with WRF v3.8, but I've tried with v3.9 and v4.0.3 and I still get the same error. Is there any fix to this issue? Or maybe another way to change the input data with the met_em files?

Hi Marc,
Yes, there is a fix for this problem beginning with V4.1. Take a look at this post that discusses the issue and the fix. Let me know if you need any assistance.

Hi Kelly,

Thanks for the response! Would I go about recompiling the code (after I move that file into the dyn_em directory) by following steps here: ?

Since you are not changing the Registry file, or anything about your configuration, you don't need to do anything except to go back to your WRF directory and recompile (./compile em_real >& log.compile). It's not even necessary to issue a 'clean -a' or to reconfigure. This won't delete any files you've created, or modifications to your namelist.