Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Issues with Geogrid and LANDUSEF

Hello,
I'm having some issues with the preprocessors. I built them directly from Github (git clone ) so I assume that they are the latest version (is there a way to check out version?). Running Geogrid w/o any extras works fine but including LANDUSEF requires to set geog_data_res = 'usgs_lakes+default'. Here, the problem is that Geogrid is looking for the subdirectory landuse_30s_with_lakes.index. I thought that I could work around the problem by moving 'modis_landuse_20class_30s_with_lakes' to 'landuse_30s_with_lakes' but the workaround does not work as the log indicates:
2023-01-25 14:49:39.502 --- *** Starting program geogrid.exe ***
2023-01-25 14:49:39.502 --- Using the following namelist variables:
...
2023-01-25 14:49:39.503 --- /
2023-01-25 14:49:39.511 --- Processing domain 1 of 1
2023-01-25 14:49:39.511 --- INFORM: For HGT_M, couldn't find interpolator sequence for resolution usgs_lakes.
2023-01-25 14:49:39.511 --- INFORM: Using default interpolator sequence for HGT_M.
2023-01-25 14:49:39.511 --- INFORM: For HGT_M, couldn't find usgs_lakes data source.
2023-01-25 14:49:39.511 --- INFORM: Using default data source for HGT_M.

The second problem is when running metgrid as the format of the output files reads:
met_em.d01.2022-12-31_00_00_00.nc
met_em.d01.2022-12-31_06_00_00.nc
...
Is this right or should it read met_em.d01.2022-12-31_00:00:00.nc ?
Thanks.
NOTE: I was trying to attach the GEOGRID.TBL.ARW file, which looks OK to me, but it doesn't have the right extension.
 
Hi,
Is there any special reason you want to use uses-lakes as input? Note that higher resolution datasets of modis_landuse_20class_15s_with_lakes and modis_landuse_20class_30s_with_lakes could be a better option.

For the metgrid output, it is correct that met_em files at various times of your study period will be produced, cuts like what showed in your post.
 
Hi Ming,
I want to use modis_landuse_20class_30s_with_lakes but my issue is that Geogrid is looking for the files at the subdirectory landuse_30s_with_lakes. I still that the issue is related to versions, but I cloned directly from Github.
Thanks.
 
In you namelist.wps, the static data option is set as :

geog_data_res = 'usgs_lakes+default'

Please take a look at your path
"geog_data_path = '/home/ubuntu/WRF-4.4/WPS_GEOG',

where you should find the subdirectory "landuse_30s_with_lakes". The data and 'index' file should be located there.

It seems that you don't have this subdirectory and/or 'index' file.
 
Hello Ming,
The directory /home/ubuntu/WRF-4.4/WPS_GEOG has the following subdirectories:
ubuntu@ip-172-31-55-165:~/WRF-4.4/WPS_GEOG$ ls
albedo_modis lai_modis_30s orogwd_10m orogwd_2deg soiltype_bot_30s varsso varsso_5m
greenfrac_fpar_modis maxsnowalb_modis orogwd_1deg orogwd_30m soiltype_top_30s varsso_10m
lai_modis_10m modis_landuse_20class_30s_with_lakes orogwd_20m soiltemp_1deg topo_gmted2010_30s varsso_2m
The attached files lists the details for the modis_landuse_20class_30s_with_lakes and WPS_GEOGsubdirectories.
Thanks.
 

Attachments

  • modis_tree.txt
    44.4 KB · Views: 6
  • wpsgeog_tree.txt
    956.2 KB · Views: 5
P.S. I believe that the issue might be originated because geog_data_res should read 'modis_30s_lake+default' at namelist.wps. This fixed the problem.
 
Last edited:
You are right. if you set

geog_data_res = 'modis_30s_lake+default',

WPS will read data from modis_landuse_20class_30s_with_lakes, which does exist in your WPS_GEOG path.
 
Maybe I'm missing something but it seemed that for the latest WPS_GEOG package with the highest resolution, the only 2 available options were either default or modis+landuse+20class_30s_with_lakes (no USGS or other MODIS dataset) even tough the GEOGRID.TBL.ARW lists many more others.
.
 
Top