Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Missing values

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have previously run WRF successfully with ERA5 output for two domains. Now I have a third domain (inside the 2nd domain basically), the same ERA5 pressure level and single level data, but metgird fails to run.

The errors are:
Field PRES, PMSL and PSFC has missing values at level 200100 at i,j= 1,40
Missing values encountered at interpolated fields. Stopping application.

I don't understand that when it has previously run perfectly with ERA5 over the same region with two domains, why it isn't running well for three domains?

I have attached the metgrid.log and namelist.wps. Would really appreciate any possible solutions to this error.


  • metgrid.log
    30 KB · Views: 95
  • namelist.wps
    1.4 KB · Views: 109
The error message comes while still processing domain 01, indicating that the problem is occurring. Is this the exact same domain 01 and 02 that you previously used? Have you modified anything in your namelist.wps file for those 2 domains? Did you change the map projection? If you are using a subset of data, then you probably downloaded it for a specific area, and if anything was modified, then you may now have points in your domain that are beyond the area of downloaded data.
Well the main difference is that the previous run was for a day, and now it is for a month. Projection system is same.
There is only a very slight difference in Domain selection area. And my downloaded data covers a region beyond the domain anyway.
would you suggest downloading the global ERA5 dataset then?
I would either suggest that, or suggest downloading an even-larger subset. Sometimes even a slight change in the domain can make a difference in the data coverage, especially if the map projection is different than the dataset. The fact that your error is happening at point (1,40) indicates that it is the very edge of the domain that is missing data.
Hi Kwerner,
I got the same error but it starts in different point in the grid:

WARNING: Field PRES has missing values at level 200100 at (i,j)=(1,1)
WARNING: Field PRESSURE has missing values at level 200100 at (i,j)=(1,1)
WARNING: Field PMSL has missing values at level 200100 at (i,j)=(1,1)
WARNING: Field PSFC has missing values at level 200100 at (i,j)=(1,1)
WARNING: Field SOILHGT has missing values at level 200100 at (i,j)=(1,1)
ERROR: Missing values encountered in interpolated fields. Stopping.
Note: The following floating-point exceptions are signalling: IEEE_OVERFLOW_FLAG

How can I fix this?

Thank you,
I first would like to apologize for the long delay in response. I've been traveling for the past few weeks and am just now catching up with forum inquiries. I'm so glad to hear that you were able to solve the problem. If you don't mind, can you let us know how you fixed it? It may help someone else in the future!
I had the same error and in my case the ERA5 region I downloaded from the CDS servers was not large enough. I had selected "sub-region extraction" and, although I calculated the extent needed for my case, it seemed to be not large enough. After slightly increasing the region by changing the "south, north, west, east" values, it worked fine.