Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

missing wrfinput_d02 file

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi all,

I am trying to run a nested simulation with 2 domains. When I run real.exe with max_dom = 2, it only creates wrfbdy_d01 and wrfinput_d01, but there is no file for d02.

The file rsl.error.0000 stops once real.exe has processed the whole time period for d01.

I will also attach my namelist.input file.

Any help with this problem would be appreciated!


  • namelist.input.rtf
    4.6 KB · Views: 59

typing tail rsl.out gives the following:

ids,ide,jds,jde 1 676 1 446
ims,ime,jms,jme -4 180 -4 70
ips,ipe,jps,jpe 1 169 1 56
ids,ide,jds,jde 88 228 33 127
ims,ime,jms,jme 83 133 28 55
ips,ipe,jps,jpe 86 123 31 45
d01 1989-12-31_21:00:00 alloc_space_field: domain 2, 12389328 bytes allocated
d01 1989-12-31_21:00:00 alloc_space_field: domain 2, 397906844 bytes allocated

Note that 1989-12-31_21:00:00 is the very end of the time period for my simulations.

tail rsl.error gives:

Time period #5150 to process = 1981-10-05_15:00:00.
Time period #5151 to process = 1981-10-05_18:00:00.
Time period #5152 to process = 1981-10-05_21:00:00.
Time period #5153 to process = 1981-10-06_00:00:00.
Time period #5154 to process = 1981-10-06_03:00:00.
Time period #5155 to process = 1981-10-06_06:00:00.
Time period #5156 to process = 1981-10-06_09:00:00.
Time period #5157 to process = 1981-10-06_12:00:00.
Time period #5158 to process = 1981-10-06_15:00:00.

Where these time periods are just under 2 years into the 10yr run time.

Other than this I'm not sure where to look for other error messages..
I guess the job is not done successfully. Otherwise you should see 'SUCCESS' at the end of the rsl files.
Note that the error message doesn't necessarily show in rsl.out.0000 and rsl.error.0000. It may appear in any of your RSL files. Please take a look at all those files and there should be some information what is wrong. Those information are important for us to figure put possible reasons for the failure.
Good evening,

I am having this same issue, but I am unable to find what isn't working in the rsl.out/error files. I was wondering if this was solved in any way.

I attached my rsl.error and rsl.out files in the file. I also attached my namelist files.

Thank you so much! :D


    99.9 KB · Views: 39
  • namelist.input
    4.3 KB · Views: 48
  • namelist.wps
    1.3 KB · Views: 41
I found no error message in your RSL files. It seems that the code successfully processed a few times of data, and then stopped suddenly.
Please recompile WRF with the debug mode, i.e., ./clean -a and ./configure -d, then rerun this case. The exact code and line where the code crashed should be provided in your rsl file, which will give you hints what is wrong.
Thank you for your help!

I was retrying it this morning and it magically worked...? So, I am not sure why it stopped last night. It might have just been a computer/processor problem.

Thanks again! :)
Thanks for the update. There is only one issue I want to address:
For nesting cases, we only need wrfinput_d02, we don't need wrfbdy_d02. So you just need to make sure wrfinpuyt_d02 is successfully generated.

Unfortunately I have not been able to fix the problem yet but I found a slightly more descriptive error message in the rsl.error files which reads:

d01 1980-01-01_00:00:00 *** Initializing nest domain # 2 from an input file. ***
-------------- FATAL CALLED ---------------
program wrf: error opening wrfinput_d02 for reading ierr= -1021

WPS ran fine and the met_em files for d02 all look good.
wrfinput_d02 does not seem to exist in the directory and was never created by running real.exe

Any ideas for how to fix this?
I looked at your namelist.inout again and I don't think a anything is wrong with it. I am suspicious that your issue might be related to other problems, although I am not quite sure yet.

Please tell more information about this case:
(1) what is your forcing data? Does met_em.d02 at the initial time exist and everything is fine with it?
(2) What version of WRF did you run?
(3) How did you compile the code and run it?
Thanks for looking into this more. I will try my best to answer your questions:

1) I am using NARR as forcing data (which has worked successfully for me in the past with a single domain - no nesting.)
met_em.d02 for the initial time exists and appears to be fine, I also confirmed that all the met_em.d02 files were linked into the directory where I am running WRF

2) I am using WRF V3.9

3) I'm not entirely sure if I'm answering this question the right way.. The code was compiled with dmpar Intel (option 15 in the configure.wrf file) and nesting option 1 (basic nesting)
The script I use to execute real.exe is attached. I used this same script previously with a single domain and it was succesful.


  • real.exe script.rtf
    687 bytes · Views: 41
Would you please let me know where you download NARR data? Which Vtable did you use to ungrib the data?
Also, please send me your namelist.wps.
I would like to repeat your case first.
By the way, is there any special reason you want to stay with WRFV3.9? Is it possible that you update to new version of WRF? We basically stopped providing support for older version of WRF.
Hi, I downloaded all my NARR data around June 2020 from here: and used Vtable.NARR to ungrib the data

I am using WRFV3.9 because it was the version my supervisor was familiar with when I began learning, but I am not opposed to updating if it might help with this case!

I have attached my namelist.wps and namelist.input


  • namelist.input.rtf
    4.6 KB · Views: 55
  • namelist.wps.rtf
    1.9 KB · Views: 54

I found another error message in my rsl.out files that may help with this issue, but I don't quite understand what the error means:

metgrid input_wrf.F first_date_nml = 1980-01-01_00:00:00
dx and dy from file 1000.000 1000.000
dx and dy from namelist 200.0000 200.0000
d02 1980-01-01_00:00:00 ---- ERROR: DX and DY do not match comparing namelist to the input file
NOTE: 1 namelist vs input data inconsistencies found.
-------------- FATAL CALLED ---------------
NOTE: Please check and reset these options

My namelist.wps and namelist.input are attached in a reply above, but I have made sure that dx and dy match in both namelists. What is causing this error??
Thanks for the update, which is very helpful.

In your nameless.input, please set
dx = 5000,1000,
dy = 5000, 1000,

Note that in nameeist.wps, the above settings should be
dx = 5000,
dy = 5000,

Please try again nd let me know whether it works.
Thanks very much! That seemed to work because real.exe got further than it did previously, unfortunately I am encountering another error now. Here is what is printed at the end of my rsl files right after the first time period for d02:
wrfinput_d02 file is still missing as well.

metgrid input_wrf.F first_date_input = 1980-01-01_00:00:00
metgrid input_wrf.F first_date_nml = 1980-01-01_00:00:00
d02 1980-01-01_00:00:00 Timing for input 7 s.
d02 1980-01-01_00:00:00 flag_soil_layers read from met_em file is 1
*** Error in boundary condition specification
boundary conditions at xs 0
boundary conditions at xe 0
boundary conditions at ys 0
boundary conditions at ye 0
boundary conditions logicals are
periodic_x F
periodic_y F
symmetric_xs F
symmetric_xe F
symmetric_ys F
symmetric_ye F
open_xs F
open_xe F
open_ys F
open_ye F
polar F
nested F
specified F
-------------- FATAL CALLED ---------------
*** Error in boundary condition specification

I haven't seen this error before and am not sure what is causing it. Any ideas?
Please set
specified = .true., .false.,.false.,
nested = .false., .true., .true.,
Then try again.