Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Modified ERA-Interim data: calc_ecmwf_p.exe warning messages

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi all,

I am trying to run WRF with modified ERA-I data (i.e., I added a perturbation to the original data). When I ran WRF using the unmodified ERA-I data, following instructions from, it worked fine, including the calc_ecmwf_p program.

Despite outputting the perturbed ERA-I data in what appears to be the same format as the original (including grib formatting, grib codes, and zaxis types), I get the following error when I run calc_ecmwf_p.exe:
Reading from FILE at time 2007-05-09_12
Found SOILHGT field in FILE:2007-05-09_12
Found PSFC field in FILE:2007-05-09_12
 WARNING First level is missing!
 WARNING No available level found near level           59 !

This warning appears for all levels (59 down to 2), and at each time. However, the program still outputs 'PRES' files that output GHT, RH, and PRESSURE at each model level (see attached 'PRES' file).View attachment PRES_2007-05-09_12.rtf

My namelist.wps file is also attached here: View attachment namelist.wps.rtf

If you could please let me know how to solve this issue with calc_ecmwf_p.exe, I'd appreciate it.
To start, you can try running rd_intermediate.exe (found in the utils directory) on the original ERA-I intermediate files and then again on the intermediate files produced from the modified ERA-I data. You can then look for obvious differences in the contents of the two sets of intermediate files.