Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Monotonically decreasing pressure

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

JCollins

New member
Hi.

I created 3 nested domains in India. When I run real.exe, stop for the following error:

Code:
Turning off use of MAX WIND level data in vertical interpolation
Turning off use of TROPOPAUSE level data in vertical interpolation
Max map factor in domain 1 =  1.01. Scale the dt in the model accordingly.
Using sfcprs3 to compute psfc
----- ERROR: The reference pressure is not monotonically decreasing
             This tends to be caused by very high topography
 (i,j) =           44          46 , topography =    4768.530      m
 k =            9 , reference pressure =    53322.79      Pa
 k =           10 , reference pressure =    53328.36      Pa
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:    1690
 In the dynamics namelist record, reduce etac from   0.2000000
-------------------------------------------
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=1
:
system msg for write_line failure : Bad file descriptor

I never saw this error before. I also did not find anything searching the Internet. I do not know how to solve it. I attach the namelist.input.
 

Attachments

  • namelist.input
    2.6 KB · Views: 145
It looks like etac is the "critical eta level" or the eta level at which the WRF model surfaces become completely isobaric. The default value is 0.2. You can try adding it to the &dynamics section of your namelist, and setting it to something like 0.1 and see if that works better for you. Take a look in the WRF/doc/ directory and you can read more about this variable in the README.hybrid_vert_coord file.
 
Hello, I have the same issue.
I reduced it as suggested:
&dynamics
etac = 0.1,
hybrid_opt = 2,
w_damping = 0,
diff_opt = 2,
km_opt = 4,
diff_6th_opt = 0,
diff_6th_factor = 0.12,
base_temp = 290.
damp_opt = 3,
zdamp = 5000.,
dampcoef = 0.2,
khdif = 0,
kvdif = 0,
non_hydrostatic = .true.,
moist_adv_opt = 1,
scalar_adv_opt = 1,
gwd_opt = 0,
/

but then I just get this error:

----- ERROR: The reference pressure is not monotonically decreasing
This tends to be caused by very high topography
(i,j) = 1 1 , topography = 1132.98169 m
k = 4 , reference pressure = 85266.0938 Pa
k = 5 , reference pressure = 85458.2500 Pa
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 1247
In the dynamics namelist record, reduce etac from 0.100000001

No matter what value I chose, the error is the same. I am using WRF Version 4.3 and WRF Pre-processing System Version 4.3

Thank you in advance
 
@wrf_1993,
Can you please attach your full namelist.input file, along with the full output log that shows the error? Thanks!
 
Top