Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

No FRC_URB2D generated in domain 3

Dear WRF experts,

I am creating a new FRC_URB2D file, but for some reason, it is not properly read and integrated by geogrid.

All my files are uploaded here including the namelist.wps, GEOGRID.TBL, and the binary files.

The urban fraction file is in the range of [0,100] (one byte). I used a scale_factor of 0.01 in the index file.
I am using MODIS 21 land use.

Any idea how to fix this?

I'll appreciate any help on this matter.
Last edited:
Your namelist.wps file has the path for 'geog_data_res' set to
geog_data_res     = 'modis_lakes+10m','modis_lakes+5m','modis_lakes+30s',
But in your GEOGRID.TBL file, you have the path for the FRC_URB2D field set to
meaning that if you set 'geog_data_res' to 'default' the geogrid program will see the new fractional dataset (assuming the 'solris' directory is in the same location as your other static directories - for e.g., in 'WPS_GEOG').
The default setting for landuse is the modis_lakes dataset, so you should change the parameter setting to
geog_data_res.  = 'default', 'default', default'
Hi Kwerner,

I followed your suggestion, but I'm still getting the same result.

Also attached is the plot of the urban fraction binary file. I ued Landsat2018 data

Attached are the screenshots. Why do domains 1 and 2 have values (actually the values are weird), while domain 3 has no value?
The figure sequence is for domain 1(top), domain 2 (mid), domain 3 (bottom)


  • Screenshot 2022-05-07 124954.png
    Screenshot 2022-05-07 124954.png
    105.6 KB · Views: 141
  • Screenshot 2022-05-07 125028.png
    Screenshot 2022-05-07 125028.png
    70.9 KB · Views: 141
  • Screenshot 2022-05-07 125101.png
    Screenshot 2022-05-07 125101.png
    80.2 KB · Views: 142
  • Screenshot 2022-05-07 125326.png
    Screenshot 2022-05-07 125326.png
    310.3 KB · Views: 141
Regarding the reason why the values are zero for domain 3, it looks like the domain is probably just located in an area within domain 2, where the FRC_URB2D field is all zero (based on the FRC_URB2D values in your domain 2 plot), but I agree that the data don't match the map you provided. I'm not certain your index file is set up correctly, though I don't know what would need to be modified. I have a Python script I'm using to try to plot your tile, based on your index and I keep getting an error that the tile does not have the expected number of elements. I'm attaching that script in case you're interested in taking a look. I can also point you to this post, where another python script is suggested for plotting. I believe in that one, the "8" in the "b =" line is referring to the tile_z value, which is =1 for you. Regardless of which script I use, I run into tile size issues, which leads me to suspect the size is wrong in your index.


    1.1 KB · Views: 18
That's great news! Do you mind saying, specifically, what the issue was so that it may help someone else in the future? Thanks!
@kwerner, I just followed the tutorial in the Documentation (Chapter 3). The problem was in the way we wrote the urban fraction file.
Just follow the steps in Chapter 3 (Creating an urban fraction field from NLCD data)
I have a similar problem.
I am using external sources of land use and urban fraction data.
I followed the steps in Chapter 3, Creating an urban fraction field from NLCD data.
But I used ArcGIS pro to convert the data into binary format.
The LU_INDEX were successfully generated in geo_em files.
And the LANDUSEF seemed to be generated from my external urban fraction data.
But the FRC_URB2D is all zero.
Can you help me to figure out why the FRC_URB2D was not generated?
I attached the binary of urban fraction data, the index file, GEOGRID.TBL, my namelist.wps, and the geo_em files.
Thank you.


    1.9 MB · Views: 13
In your GEOGRID.TBL.ARW file, under FRC_URB2D, you have the line
interp_option=default: average_gcell(1.0)+four_pt
Can you change that "1.0" to "2.0" and see if that helps? I ran geogrid with your namelist and FRC_URB2D data, but with 2.0 and it seems to work just fine.
Hi all:
I have a question during creating FRC_URB2D.I use the GlobeLand30 to create FRC_URB2D.the datatype is 2,but the uf.c( must requre datatype to be 1.So I use python script or arcgis pro to convert the datatype.After converting datatype.then i use uf.c to create RFC_URB2D,For the output ,i use to deal it,and then it shows the error at below.It means that the tile_x and tile_y has changeg.That‘’s why?
would you give me some idea to solve it ?


  • erro.png
    6.2 KB · Views: 3
Since your question is somewhat different than the original question asked in this thread, will you please post your question as a new thread. This helps to keep the forum organized by single issues, which is better for readability and searchability. Thanks!