Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

no leap years run

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
hello everyone.
I need help, I need to run with the CCSM CMIP5 data, which has no data for 29 febuary, it doesn't take leap years, so I need to configure wrf to use no leap years.
I did as the manual says, putting -DNO_LEAP_CALENDAR in the ARCH_LOCAL, in configure.wrf.
But when the run comes to 29 february of a leap year still look for it, and it fails because (for example) met_em.1980-02-29 doesn't exist, I don't have that data.
Someone could help me?
Thank you very much.
A hug.
Would you please confirm that you did type ./clean -a, then add the option -DNO_LEAP_CALENDAR and recompile WRF?
By the way, which version of WRF are you working with? If it is an older version, can you try WRFv4.2?
Ok I'm stupid.
I don't know why I didn't realise to do the clean -a thing.
Thank you very much Ming, it is solved now.
A hug
Thanks for letting me know. It saved me time to test this option. Sometimes the old options might be broken due to newly added codes, which is what we definitely need to fix.