Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

No supported platforms available for configuring WPS

Henry P

New member
Hello,

I am following the WRF online tutorial and managed to build WRF. When configuring WPS, however, there's no available supported platforms for me to opt for.
It seems everyone is getting through smoothly and so I wasn't able to find solutions from any previous posts. Any hints about this issue?

PS. I am using Mac Studio running with M1 Max on Ubuntu 23.04.
1695723561256.png
 
Hi,
Can you attach the configure.wrf file you used for the WRF installation? Also, if you happened to have logged out of your terminal environment between compiling WRF and WPS, you may need to reset your paths to make sure it's able to find the right compilers.
 
Hi,
Can you attach the configure.wrf file you used for the WRF installation? Also, if you happened to have logged out of your terminal environment between compiling WRF and WPS, you may need to reset your paths to make sure it's able to find the right compilers.
Hello,
I have attached the configure.wrf file used for the WRF installation.
I encounter the issue when I configure WPS right after the compilation of WRF.
 

Attachments

  • configure.wrf.zip
    5.4 KB · Views: 1
It may be that the configure.defaults file doesn't contain any configuration "stanzas" that match the output of `uname` and `uname -m` from your system.

For example, on the workstation in my office, `uname` gives "Linux" and `uname -m` gives "x86_64"; the configuration scripts for WRF would then present any of the "ARCH" options in the configure.defaults file that contain "Linux" and "x86_64".

A simple fix in your case may be to add the output of `uname -m` to the "ARCH" lines of any configuration options that you'd like to try in the configure.defaults file.
 
It may be that the configure.defaults file doesn't contain any configuration "stanzas" that match the output of `uname` and `uname -m` from your system.

For example, on the workstation in my office, `uname` gives "Linux" and `uname -m` gives "x86_64"; the configuration scripts for WRF would then present any of the "ARCH" options in the configure.defaults file that contain "Linux" and "x86_64".

A simple fix in your case may be to add the output of `uname -m` to the "ARCH" lines of any configuration options that you'd like to try in the configure.defaults file.
This works for me. Thank you very much for your help! ☺️
 
Top