Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

No variation of T2

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Hello everyone,
I'm running WRF model in a domain placed in Panama using the attached namelists. Looking at T2 variable it barely changes during the whole run (three days) which doesn't make sense as in reality there are changes of 4-6K between night and day, we sould see some kind of pattern with these variations.
I assume there is a problem in the namelist.input. I have tried other parameterizations in the &physics section but T2 is quite the same. Maybe in the &bdy_control section something doesn't make sense (I'm not familiar with these options and use suggestions from another post, so I would'nt know what to change).
This is a serious problem and any advice to solve it will be welcome,


  • namelist.input
    6.1 KB · Views: 24
  • namelist.wps
    1 KB · Views: 17
  • t2_1.png
    19.6 KB · Views: 353
I suppose this is a real-data case. Pleas let me know if I am wrong.
For real-data case, please change your namelist options as follows:
bl_pbl_physics = 1, 1,
radt = 5, 5,
cu_physics = 0, 0,
diff_opt = 2, 2,
km_opt = 4, 4,
ptop = 5000,

The try again.
Hi Ming Chen, thanks for your reply, I will write down what you suggested.
I thought for grids of 5km resolution it was accepted to use a cumulus option, could you explain me why you turn in off for both domains?
I changed isfflx option to 1 and got reasonable temperatures, I read it is related to surface fluxes but any additional information about this would be appreciated.
5km resolution is a typical grey-zone resolution. The cumulus scheme could be appropriate or not for this resolution. Personally I prefer to turn off cumulus scheme at this resolution because I found this could give me better results compared to when cumulus is on.

we always set isfflx=1 when running real-data cae. This option controls the surface heat flux transfer. You can look into the codes and see how it operates. I am sorry we don't have specific document to describe this namelist option.