Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

NOAH-MP error with GFS

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

gverri

New member
Hi,
I recently moved to WPS V3.9.0.1 because I need to deal with the current version (July 2019) of NCEP GFS forecast files as forcing data.
WRF is still v3.6.1 and it works well when I perform forecast experiments while working with NCEP GFS analyses on July 2018 I face the following error and wrf.exe blows up:

critical problem: ZLVL <= ZPD; model stops
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 4160
STOP in Noah-MP
-------------------------------------------

I checked metem files and real.exe and everything seems to be normal.
Thanks for help

Giorgia
 
Giorgia,

I am a little confused by your last sentence. Do you mean that you have no problem when using older data, along with WPSV3.9.0.1 and WRFV3.6.1?
Can you attach a couple times periods of your met_em* files, along with your namelist.input file so that I can try a test here? And just to verify - is your V3.6.1 version of WRF non-modified (as in, you have not made any modifications to the code)? Thanks!
 
Hi,
Thanks for your promptly reply.
To be more clear: I'm working with WPS 3.9.0.1 + WRF 3.6 (I did no changes to the code)
It seems to me that the model set up works correctly after the last release of GFS data. Thus I attached as an example an experiment I performed on August 2019
We fail when we try to perform simulation in the past, I attached an experiment on July 2018
I hope I clarified
Thanks
Giorgia
 

Attachments

  • working_exp_august2019.zip
    212.2 MB · Views: 45
  • Non_working_exp_July2018.zip
    194.4 MB · Views: 52
Hi,
I ran the following tests:
1) your input, your namelist, V3.6.1 - I get the same error that you're seeing.
2) your input, your namelist, V4.1.2 - it runs fine without errors
3) your input, my own basic namelist (only modifying necessary dimesions, etc.), V3.6.1 - I still see the same error.
4) I created my own WPS input (with V3.9.0.1), with GFS files (0.25 degree data) for the exact same times, using your dimensions, etc., ran wrf with your namelist, V3.6.1 - it runs without a problem.

So it seems to be a problem with your particular met_em* files. I'm not sure what the difference was in our WPS set-up. If you'd like me to create WPS met_em* files, using your exact WPS namelist, attach that, and I'll give that a shot. Whatever the problem was, it seems that it was resolved, likely with Noah-MP code updates between V3.6.1 and V4.1.2. There have been a LOT of code changes in that routine since then, though, so it would be quite difficult to narrow that down. I don't suppose using WRFV4.1.2 is an option for you?
 
Hi,
thanks for support.
I'd like to catch up with your test 4. Please find enclosed WPS namelist, and also Vtable and METGRID.TBL
Maybe, am I using the wrong tables?
Thanks
Giorgia
 

Attachments

  • namelist.wps
    972 bytes · Views: 53
  • METGRID.TBL
    34.2 KB · Views: 52
  • Vtable.GFS.txt
    8.4 KB · Views: 47
Hi Giorgia,
Okay, I used your namelist.wps file, your Vtable, and your METGRID.TBL, with the GFS files I downloaded, and when I run with WRFV3.6.1, it still runs okay. The only difference I made in the namelist.wps file is to use the default static landuse setting (geog_data_res = 'default', 'default') as I don't have your srtm and eudem datasets. So the only 2 differences seem to be:
1) the actual GFS files we are using
2) your geog static data

So I would like for you to do 2 tests.

1) I am going to provide the GFS files I'm using. It was too large to attach, so you'll need to download it from this link (look for gverri_gfs_files.tar.gz):
https://nextcloud.mmm.ucar.edu/nextcloud/index.php/s/o8nYwN3nHMQr1Ov
Can you use these for a short (3 hour) run to see if they make any difference? You'll need to re-run ungrib, metgrid, real, and wrf.

2) If the above doesn't make a difference, can you set geog_data_res = 'default', 'default', rerun geogrid, metgrid, real, and wrf, and let me know if there is any change.
 
Top