Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

P_TOP issue for d02 (maybe)

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I'm not sure if this is an issue that should be posted in real.exe or wrf.exe, my error comes up when running wrf.exe, but I believe the issue stems from real.exe or maybe somewhere in WPS.

The setup
I am running WRF 4.1.4 on Cheyenne and have successfully completed a run with 2 nested domains using ERA-Interim as my input data. I am now trying to run a similar simulation with a slightly different domain (only 1 nested domain) using ERA-5 as my input data. I've run WPS and real.exe with the new settings and have received success messages for each step. I am using Vtable.ECMWF.

The issue
When I run wrf.exe, the program fails immediately. I can't determine what the errors (attached) are trying to tell me. However, I have noticed that the variable P_TOP in my wrfinput_d02 file is an underscore. I received an error while troubleshooting stating that P_TOP_REQUESTED in my namelist did not match P_TOP in my input files, but cannot replicate that error message now, so maybe this isn't the source of the error, but it seems suspicious to me.

Does anyone know what these error messages might mean? Is this an issue with the input data or maybe an issue stemming from the number of nodes/processors I'm requesting?

My WPS directory can be found here: /glade/scratch/sarahm/WPS
and my WRF run directory is here: /glade/work/sarahm/WRFV4.1.4/run



  • namelist.wps
    3.1 KB · Views: 19
  • namelist.input
    4.6 KB · Views: 19
  • rsl.out.0000.txt
    2.3 KB · Views: 19
  • rsl.error.0000.txt
    3.5 KB · Views: 23
Hi Sarah,
I'm not sure about the p_top issue, as I can't see that error in any of your rsl files. There is a special process for processing ERA5 data, however. Can you take a look here and make sure you followed all of those steps (specifically regarding the invariant file)? Thanks!

Thanks for your reply! I didn't know about this special process, so I made those changes. However, I'm still getting an error when running wrf.exe even though all of WPS and real.exe gave me success messages.

This is the error:

d01 2015-05-01_00:00:00  alloc_space_field: domain            2 ,                9104400  bytes allocated
d01 2015-05-01_00:00:00  alloc_space_field: domain            2 ,               68340212  bytes allocated
d01 2015-05-01_00:00:00 *** Initializing nest domain # 2 from an input file. ***
d01 2015-05-01_00:00:00 med_initialdata_input: calling input_input
d01 2015-05-01_00:00:00  Input data is acceptable to use:
forrtl: severe (64): input conversion error, unit -5, file Internal Formatted Read
Image              PC                Routine            Line        Source             
wrf.exe            00000000033DBFFE  Unknown               Unknown  Unknown
wrf.exe            0000000003405D24  Unknown               Unknown  Unknown
wrf.exe            00000000034040E2  Unknown               Unknown  Unknown
wrf.exe            00000000012614C3  Unknown               Unknown  Unknown
wrf.exe            00000000013153AD  Unknown               Unknown  Unknown
wrf.exe            00000000013D534A  Unknown               Unknown  Unknown
wrf.exe            00000000013C8D3D  Unknown               Unknown  Unknown
wrf.exe            0000000000555B3E  Unknown               Unknown  Unknown
wrf.exe            0000000000406201  Unknown               Unknown  Unknown
wrf.exe            00000000004061BF  Unknown               Unknown  Unknown
wrf.exe            000000000040615E  Unknown               Unknown  Unknown       00002AB95740D6E5  __libc_start_main     Unknown  Unknown
wrf.exe            0000000000406069  Unknown               Unknown  Unknown

Thanks again for your help!
Can you please package all of your rsl.error* files together as a single *.tar file and attach that, along with your updated namelist.input file so that I can look at those more closely? Thanks!
I've attached the rsl.error* files and namelist.input. Thank you again for the help!!


  • rsl_files_sm.tar
    5.8 KB · Views: 18
  • namelist.input
    4.6 KB · Views: 22
Thanks for sending those. I took a closer look at your namelist.wps file, which shows me that you're using several different input data types:
fg_name = 'FILE', 'SSMI', 'SNOWSI', 'ALBSI', 'ICEDEPTH',

If you were to only use the FILE* data files, would you still get this same error?
Sorry for the delayed reply. Thank you for looking at my files!

I just tested it using only the FILE* data and it did produce the same error.
Ok, thanks for trying that. Can you send a couple times of your met_em* files so I can try to repeat this? If the files are too large to attach, please see the home page of this forum for instructions on sending large files. Thanks!
I've attached a zip file of a few met_em files, including both domains at the first and last time steps. Let me know if I can provide any other files to help diagnose the issue. Thanks!!


    39.7 MB · Views: 13
Thanks for sending those. I was able to run wrf just for the initial time and didn't get the error you're getting. I assume you're using the namelist.input file you sent earlier in this thread? If so, I do notice that your time_step is entirely too large, which typically will cause instability and CFL errors in the rsl files, but I wonder if it has anything to do with the error you're seeing. The time_step should be no larger than 6xDX. I tried using 45 and that worked.