Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Perturbing wind fields

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I am trying to subtly perturb surface winds along the Antarctic coastline in a PolarWRF simulation. I can add a small perturbation on the cells in question and real.exe runs correctly to create the wrfinput, wrfbdy, wffdda and wrflowinp files.

However, once I start up WRF it crashes instantly with next to no error information, just a stack trace many levels deep into the fortran code.

I can confirm that an unperturbed set of inputs works fine and the magnitude of perturbation is only in the range of +- 6ms on the bottom level of the VV variable. Running real.exe appears to place this perturbation signature in the relevant V10 field as well.

I have dug into the code and it is not immediately apparent why this is happening - my first thought was that WRF simply can't handle the discontinuity at the coastal margins.

I've tried much lower levels of perturbation (i.e. < +-1ms) but still end up with the same result. Is it possible that I might need to perturb multiple levels and slowly dissipate/reduce the perturbation going up? Or do multiple variables need to be perturbed in concert to the same degree (i.e. surface temperatures)?

Any assistance would be greatly appreciated!

Kind Regards,

Hi Ben,
Unfortunately our group does not develop or support the Polar WRF version of the model. It was developed by a group at Ohio State University. Their webpage can be found here:

Perhaps they have a contact or support group that would be able to help you.
Hi kwerner,

Thanks for the reply - it turns out in preparing the original perturbation a single missing value appeared at the pole.I believe this was the issue as I've been able to run the model by filtering out missing values.

I'm now getting another issue with some of my ensemble members crashing with a status 135 after over a week of model time, but I'll raise another issue for that one.

Thanks again!