Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problem at Installation

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Dear Sir/Madam,
I want to install the WRF-Hydro. I have installed Netcdf_C, Netcdf_F and Mpich. Whenver I compile, it does not work for me - no .exe files are produced. I have added my compilation log with this. My bash files have these in it -

export CC="gcc"
export CXX="g++"
export FC="gfortran"
export FCFLAGS="-m64"
export F77="gfortran"
export FFLAGS="-m64"
export NETCDF="/usr/local/netcdf"
export NETCDF_INC="/usr/local/netcdf/include"
export NETCDF_LIB="/usr/local/netcdf/lib"
export NETCDF=/usr/local/netcdf
export PATH=$NETCDF/bin:$PATH
export LDFLAGS=-L/usr/local/netcdf/lib
export CPPFLAGS=-I/usr/local/netcdf/include
export JASPERLIB=/usr/local/grib2/lib
export JASPERINC=/usr/local/grib2/include
export MPICH=/usr/local/mpich
export NETCDF_classic=0
#export WRF_EM_CORE=0
#export WRF_NMM_CORE=0
export WRF_HYDRO=1
export HYDRO_D=1
export NCEP_WCOSS=0
ulimit -s unlimited

What should I do now? Please help.



  • log.compile
    37.1 KB · Views: 70
This forum is for Basic WRF, WRFDA, WRF-Chem, and MPAS. To obtain support for the WRF-Hydro model, please visit this website:
Dear Sir,
I have mailed them, but did not get any response yet.
I am in really a very bad situation with this. Any help in this regard, would be greatly appreciated.
I have tried a few things, still I get these errors.
I know it's not the place and it's really rude to ask again.
But, can anybody help me in this regard?


  • compile.log
    45.9 KB · Views: 76

Your error is this:

/bin/sh: 1: mpif90: not found

So, compile script cannot find mpi fotran compiler. It is either:
- not in your path, or
- not built at all

So as you said you did compiled mpich, then I assume that it is not in your path. Concentrate your efforts in fixing that so that your compile script can find mpif90.

Looking at your first post, I see this:
export MPICH=/usr/local/mpich

assuming, your mpich installation is in /usr/local/mpich

but, you have
export PATH=$NETCDF/bin:$PATH

and I can't see any reference of setting mpich directory as part of PATH. As /usr/local/mpich is not standard part of PATH on linux, you need to add it. For example, try to add this also in your script:
export PATH=/usr/local/mpich:$PATH

or, if your mpif90 is located in /usr/local/mpich/bin (maybe?) then instead of above, add
export PATH=/usr/local/mpich/bin:$PATH

Or any path wherever it is located...

Hope this helps,
Dear Sir,
It worked!!!
Thank you so much!!!
I can't tell you how releieving it feels!!!
Thank you again!!!
Sincerely -