Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

problem installing cygwin

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


For some reason, I have not been able to get Cygwin/X, the X-11 terminal emulator (which plotgrids_new.ncl requires to run), to install properly on my PC, even though I followed the steps in the User's Guide. One thing that I did notice however as I tried to install it, was that the option Unix/binary never appeared. Every time I installed Cygwin, the "X" icon never appears. I have written a couple of times to the ncl-install email address that is given in the User's Guide, but there doesn't seem to be anyone there.
I've moved this inquiry to its own topic since it does not apply to the same problem listed in the one you posted to.

As for this issue, unfortunately our group only supports the WRF model, and does not manage or support Cygwin or X11 installations. We also do not support processes on Windows machines. If you're having trouble installing these, you'll need to contact the Cygwin/X group to discuss the issue. the NCL group would also not be able to help. I apologize for the inconvenience.
Update on Cygwin/X: the communication with ncl-install was unusual, so I gave on Cygwin/X. The I installed Xming and it did even less: it only make a non-operable icon. So i tried X-win32, and that worked once I entered the temporary licensing key that came with the 30-day free offer.
Glad to hear you found a work-around! Hopefully your update will help someone else in the future.