Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

problem running real.exe, bad date in namelist


New member
I am having strange error while running real.exe, using ERA5 data. I downloaded the ERA5 pressure/surface level data from the RDA website:

I am using the standard Vtable.ECMWF file for both surface and pressure level data. I believe there is no need to run ecmwf_calc_p.exe program for the above dataset so I am not running it.

Ungrib, metgrid all went well. The met_em* files generated look all good. The real program runs fine if I run only for a 2-3 day period. But when I try to run it for the entire 1-month period, it gives me this error:
d01 2020-03-29_01:00:00 Timing for output 1 s.
d01 2020-03-29_01:00:00 Timing for loop # 98 = 1 s.
-------------- FATAL CALLED ---------------
error opening for input; bad date in namelist or file not in directory

The file is there, and the date is fine too so this is a strange problem. What is noticeable is that when I change the initial date to another day, the error also gets shifted to another met_em* file as if the error occurs at a certain time interval.

This issue was noted in a previous post here:

Although the above post says that the problem was solved, it was not actually solved. The suggested workaround in another post is not actually a solution. So I would greatly appreciate if someone could look into this issue.

Note: I compiled WPS using GNU compilers.
Can you attach your full real.exe error log (e.g., rsl.error.0000) and your namelist.input file? Can you also issue the following:

ls -ls met_em* >& met.txt

and attach that met.txt file, as well? Thanks!