Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problem with hybrid vertical coordinate

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am trying to run ndown.exe. I get errors: ERROR: The reference pressure is not monotonically decreasing
I have tried with reducing etac value to as low as 0. But I still get the error. Is there any other option that I can try without possibly changing the domain? I have looked at similar posts in the forum, but none of them addressed how this should be handled.

taskid: 0 hostname:
 module_io_quilt_old.F        2931 T
 Ntasks in X            2 , ntasks in Y            3
  Domain # 1: dx = 10000.000 m
  Domain # 2: dx =  3333.333 m
   max_ts_level must be <= number of znu half layers
   max_ts_level is reset to the number of znu half layers
 Parent domain
 ids,ide,jds,jde            1         300           1         232
 ims,ime,jms,jme           -4         157          -4          84
 ips,ipe,jps,jpe            1         150           1          77
DYNAMICS OPTION: Eulerian Mass Coordinate
   alloc_space_field: domain            1 ,              570411100  bytes allocated
   Input data is acceptable to use: wrfout_d01_2018-04-10_00:00:00
----- ERROR: The reference pressure is not monotonically decreasing
             This tends to be caused by very high topography
 (i,j) =            1           1 , topography =   0.2310071      m
 k =            1 , reference pressure =    8697.281      Pa
 k =            2 , reference pressure =    8700.000      Pa
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:    1239
 In the dynamics namelist record, reduce etac from   0.0000000E+00
Abort(1) on node 0 (rank 0 in comm 0): application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
forrtl: error (78): process killed (SIGTERM)
Image              PC                Routine            Line        Source             
ndown.exe          0000000002A7FC7E  for__signal_handl     Unknown  Unknown
libpthread-2.17.s  00002B87C14FA5F0  Unknown               Unknown  Unknown
libpthread-2.17.s  00002B87C14F971B  read                  Unknown  Unknown   00002B87C0A2E76F  Unknown               Unknown  Unknown   00002B87C0A2DB02  Unknown               Unknown  Unknown   00002B87C0348382  Unknown               Unknown  Unknown   00002B87C001A3C5  MPI_Abort             Unknown  Unknown  00002B87BFC7A12D  mpi_abort             Unknown  Unknown
ndown.exe          0000000000B30DE6  Unknown               Unknown  Unknown
ndown.exe          000000000086D5FD  Unknown               Unknown  Unknown
ndown.exe          000000000166AF15  Unknown               Unknown  Unknown
ndown.exe          000000000041632E  Unknown               Unknown  Unknown
ndown.exe          00000000004124DE  Unknown               Unknown  Unknown       00002B87C1729505  __libc_start_main     Unknown  Unknown
ndown.exe          00000000004123E9  Unknown               Unknown  Unknown
This error is attributed to the fact that pressure at higher model levels are larger than that at lower model levels. Apparently the input data is not physically reasonable. If you run ndown, the input data should be from wrfout. I am suspicious that something could be wrong either in the previous WRF run, or in the process of running ndown. Please check your wrfout data from your previous WRF run, and make sure you follow the correct steps to run ndown.