Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problems adding invariant SST from OI to ERA5 data

rjhall

New member
I am using ERA5 data from Copernicus, and wanting to use an initial SST field from the OI dataset, using a different date to those of the model run. I have converted the SST to intermediate format using the pywinter package and checked that when I convert it back to netcdf it matches the original SST timestep field.
I am using ERA_INVARIANT and the SST intermediate file in the constants name section of WPS. I have changed the date of the SST intermediate file to match the first timestep of the model run.
Everything runs and I get model output. However, when I look at the SST field in the model output it makes no sense. However if I just run everything with the ERA5 SST field I can see a sensible SST field in the output. I don't know what is wrong I'm afraid. Attached are screenshots of the two different SST fields and the namelist.wps file
 

Attachments

  • namelist.wps
    696 bytes · Views: 2
  • SST_from_ERA5.png
    SST_from_ERA5.png
    76.4 KB · Views: 4
  • SST_from_OI.png
    SST_from_OI.png
    36.9 KB · Views: 5
Thank you. I have tried to modify METGRID.TBL as shown. If I add "from input =SST" as shown, the attached error is returned. If I just add the landmask as shown then the whole thing runs but with the same problem as before. Should I be using a different land mask for the OI SST? If so where do I obtain this? To reiterate, I didn't use ungrib on the OI dataset, as it is supplied as netcdf, so I used the pywinter package to create the intermediate file, without the use of a Vtable. I think there is something that I am not understanding here!
 

Attachments

  • METGRID.TBL_entry _for_SST.png
    METGRID.TBL_entry _for_SST.png
    9.7 KB · Views: 3
  • returned_error.png
    returned_error.png
    22.4 KB · Views: 3
Top