Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Problems Building Executables

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

bbleckly

New member
Hi Everyone,

I am trying to compile WRF v4 but am receiving an error saying that there were problems building the executables.

What fix is needed to ensure that it compiles correctly and builds these executables?

Thanks in advance :)
 

Attachments

  • configure.wrf
    20.2 KB · Views: 62
  • log.compile
    700 KB · Views: 79
Hi,
It looks like you may be trying to build WRF with NetCDF-4, as the compile log is complaining about not having the required HDF5 files. It is perfectly fine to use NetCDF-4, but if you are planning to use the NetCDF-4 specific capabilities (such as compression), there are additional libraries that you must install. You can follow guidance on this page for building it correctly.

However, most WRF users do not need the extra NetCDF-4 capabilities. If that's the case, then when you build NetCDF, you should simply turn off the NetCDF-4 capabilites. Based on the paths in your compile log, it looks like you're already following the online compilation tutorial, but take a look again at the section for installing NetCDF, and make sure you are using the setting to turn off the V4 capabilities.
 
Hi,

I have been following the online compilation tutorial but did initially use the enable-netcdf-4 option as I read somewhere that this would be needed to incorporate PREPBUFR files. Also, when I tried to configure WRF using the --disable-netcdf-4 option I received the Warning message shown in the capture.

Setting NETCDF_classic=1 and then rebuilding with the --disable-netcdf-4 option still fails to build the executables. I am trying to build the em_real case and have followed the online tutorial. It worked for V3.9 but now that I have upgraded to V4 (to include WRFDA and WRPLUS) it won't compile and run.

The attached configure.wrf and log.compile files are from today's testing (sorry for the delay but I didn't have internet over the weekend).

Thanks for your help!
 

Attachments

  • Capture.PNG
    Capture.PNG
    13 KB · Views: 1,527
  • configure.wrf
    20.4 KB · Views: 69
  • log.compile
    732.4 KB · Views: 68
Hi,
Since you are trying to build WRFDA, then you probably do need the NetCDF-4 capabilities, which means that you will need the library HDF5 installed. The error you are receiving seems to indicate that you are missing some of the HDF5 libraries. You will need to verify that you build them correctly and have your path pointing to them. The best advice I can give is to follow what is instructed on this page. Unfortunately we are not the developers or supporters of the HDF5 or NetCDF libraries. We can provide a bit of guidance, but if you continue to have problems, you will need to discuss the problem with a systems administrator at your institution.
 
Hi,

I have followed those instructions and when I configure WRF it is now telling me that it will build with NETCDF4 and HDF5 so I believe these are installed correctly, see capture below.

However, it is still having a problem building the executables when I try and compile the em_real case. Is this still missing some of the HDF5 libraries even though the configure script has identified that it will install with NETCDF4 and HDF5?

Thanks for all of your help?
 

Attachments

  • Capture1.PNG
    Capture1.PNG
    22.4 KB · Views: 1,510
  • configure.wrf
    20.4 KB · Views: 63
  • log.compile
    54.4 KB · Views: 63
Can you issue the following commands:

echo $LD_LIBRARY_PATH >& ld_lib_path.txt

ls -ls /home/bbleckly/Build_WRF/LIBRARIES/hdf5-1.8.21/lib >& ls_lib.txt

and then send those 2 text files? Thanks!
 
The two files are attached.

Thanks!
 

Attachments

  • ld_lib_path.txt
    100 bytes · Views: 84
  • ls_lib.txt
    889 bytes · Views: 85
Thank you for attaching those. It looks like you are missing some of the libraries in your lib/ folder for the HDF5 installation. These are the files we have built on our server:
Code:
libdynlib1.la        libdynlib3.so        libdynlibdiff.la     libdynlibls.so       libhdf5.dylib        libhdf5_hl.100.dylib libhdf5hl_fortran.la
libdynlib1.so        libdynlib4.la        libdynlibdiff.so     libdynlibvers.la     libhdf5.la           libhdf5_hl.a
libdynlib2.la        libdynlib4.so        libdynlibdump.la     libdynlibvers.so     libhdf5.settings     libhdf5_hl.dylib
libdynlib2.so        libdynlibadd.la      libdynlibdump.so     libhdf5.101.dylib    libhdf5_fortran.a    libhdf5_hl.la
libdynlib3.la        libdynlibadd.so      libdynlibls.la       libhdf5.a            libhdf5_fortran.la   libhdf5hl_fortran.a

I would try installing it again, and if you are still having trouble with it, I would advise to check with a systems administrator at your institution to see if they can help you get it installed correctly, and the paths set up correctly.
 
Top