Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Process interuptted when running wrf.exe

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello, everyone! I encountered problems when running wrf.exe. The error told that 'forrtl: error (69): process interrupted (SIGINT)'. I have checked all the error files but there were not evident clues.
I tried to reduce the time step and change the microphysics scheme, but it didn't work.
Attached are the namelist.wps and namelist.input and some of the rsl.error files.
Thank you for reading and helping!!!


  • rsl.error.0000.txt
    3.7 KB · Views: 30
  • rsl.error.0010.txt
    3.1 KB · Views: 21
  • rsl.error.0059.txt
    1.8 KB · Views: 24
  • rsl.out.0000.txt
    2.3 KB · Views: 25
  • namelist.input
    5.3 KB · Views: 25
  • namelist.wps
    749 bytes · Views: 21
Hi, cicicsx ,
I guess you are not running the standard WRFV4.2. Please let me know if I am wrong.
If you modified the code, please describe what you have changed.

Looking at your rsl file, I found that this case failed immediately. This indicates that either the input data is wrong, or it is a memory issue.
Since this is a big case with 1409 x 1081 grids, I would suggest you retry with larger a memory. For example, using more processors will give you larger memory.

Please try and let me whether it works. Thanks.

Dear Ming,
I have checked the log files that I was using the original WRF-4.2 and WPS-4.2.
Attached are the log files and one of the input data.The time interval is 3h. 120 executive hosts may be enough?
Thank you for your help!


  • icbc_428622_stdout.txt
    5 KB · Views: 18
  • icbc_428622_stderr.txt
    34.4 KB · Views: 21
  • 微信图片_20210629090112.png
    32.7 KB · Views: 726
  • 微信图片_20210629090327.png
    10 KB · Views: 726
    44.1 MB · Views: 23
Hi, cicicsx,
I found some namelist options are not included in standard WRFV4.2. For example,
numtimes_2d = 1,
caps_interval_profile = 0,
caps_out_profile = 361,
caps_num_profile = 4,
caps_is_profile = '500,475,446,463',
caps_js_profile = '164,272,254,228',
Would you please clarify what they are? I am just curious and I don't think these options are the reason for the case to crash.

Please tell me the command you used to run WRF, e.g., mpirun -np 16 wrf.exe ?
I am specifically concerned of the number of processors you use. This will tell us whether this is a memory issue.
Hi, Ming
These are some diagnostic-related option. Since this namelist.input is given by my senior, I'm not very familiar with the explicit meanings.
I used 120 pocessors to run the wrf task, and I tried to add to 140, but it still failed.
Thank you for your help!!


  • 微信图片_20210629094235.png
    10.4 KB · Views: 725
Hi cicicsx,

The options I listed in my previous post are newly added and they should be related to modified codes. Based on this, I don''t think you are running standard WRFV4.2. Without knowing details of the modified codes, it is hard to detect what is wrong. Therefore, I would suggest you download the standard WRFV4.2 and WPSV4.2, compile the code, and start from WPS to produce initial and boundary condition. Then remove those options not included in standard WRF, and rerun this case. Please let me know whether the case works.

If not, please send me your namelist.wps and enamelist.input to take a look.

Sorry for the delay of response! I searched for the keyword of error in this forum, and found one having nearly the same problem with similar namelist.input.
Based on the conversation, I have sovled this problem by changing the initial and lateral boundary field. B!description
But I did not understand the underlying reason for the problem yet.
Hello, Ming
Sorry for the delay of the response. I have solved this problem by changing the initial and lateral boundary field which can be downloaed at!description.
I searched the keyword of error files in the forum and found one topic with nearly the same question and namelist.input file.
I referred to the answers and finally solved.
Thank you for your generours help!!!