Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I have installed WRF 4.2.1 on a server with 28 cores and 62 GB of RAM with gfortran, and I try to run a simulation with WRF-Chem, but when I run the real.exe appears this error: 'mpirun noticed that process rank 3 with PID 0 on node climserver exited on signal 11 (Segmentation fault).'
I provide the namelist.input, rsl.error.000 and the rsl.out files.

I hope someone can help me thank you.

Blanca Rios


  • namelist.txt
    8.5 KB · Views: 49
  • rsl.error.txt
    1.9 KB · Views: 60
  • rsl.out.txt
    9.8 KB · Views: 48
If you build wrf WITHOUT the chemistry option and try to run real.exe, do you get the same error?
Hi, thank you for anwer
When I quit the chemistry option I don't have an error. But when I put the chem_opt=112 the real.exe send me the same error. I changed my namelist because I noticed that I had some errors. But even so, I keep getting the same error.
I provide mi new namelist


  • namelist_mozcart.txt
    8.9 KB · Views: 56
  • rsl.error.txt
    2 KB · Views: 51
Thanks for doing that test. Since this seems to be specifically related to the WRF-Chem build of the model, can you please re-post your problem in the appropriate topic under the chemistry section of this forum? A different support group takes care of those topics, so I'm hoping they will be able to provide the correct assistance. Thanks!

I am facing the same error as well. I can run the real.exe without chem options in the input file. As soon as I include chem options I get the following error message,

taskid: 0 hostname: Saurabh
module_io_quilt_old.F 2931 T
Ntasks in X 2 , ntasks in Y 2
Domain # 1: dx = 10000.000 m
No git found or not a git repository, git commit version not available.
Parent domain
ids,ide,jds,jde 1 100 1 69
ims,ime,jms,jme -4 57 -4 41
ips,ipe,jps,jpe 1 50 1 34
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 611548640 bytes allocated
d01 2018-10-07_12:00:00 Yes, this special data is acceptable to use: OUTPUT FROM METGRID V4.3
d01 2018-10-07_12:00:00 Input data is acceptable to use:
metgrid input_wrf.F first_date_input = 2018-10-07_12:00:00
metgrid input_wrf.F first_date_nml = 2018-10-07_12:00:00
d01 2018-10-07_12:00:00 Timing for input 0 s.
d01 2018-10-07_12:00:00 flag_soil_layers read from met_em file is 1
d01 2018-10-07_12:00:00 Turning off use of MAX WIND level data in vertical interpolation
d01 2018-10-07_12:00:00 Turning off use of TROPOPAUSE level data in vertical interpolation
Max map factor in domain 1 = 1.03. Scale the dt in the model accordingly.
Using sfcprs2 to compute psfc
d01 2018-10-07_12:00:00 No average surface temperature for use with inland lakes
Assume Noah LSM input
d01 2018-10-07_12:00:00 forcing artificial silty clay loam at 4 points, out of 1700
d01 2018-10-07_12:00:00 Timing for processing 0 s.
Subroutine input_chem_profile:

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x1502e293fd21 in ???
#1 0x1502e293eef5 in ???
#2 0x1502e1a0920f in ???
#3 0x55892e65a875 in ???
#4 0x55892e6615aa in ???
#5 0x55892c38fbbe in ???
#6 0x55892c39071d in ???
#7 0x55892c3827e2 in ???
#8 0x1502e19ea0b2 in ???
#9 0x55892c38281d in ???
#10 0xffffffffffffffff in ???

Has anyone been able to solve this problem?
Please see my message above about posting this question in the chemistry section of the forum, since this seems to specifically be related to chemistry. Thanks.