Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

REAL: error opening wrfinput for writing

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I installed WRFV4.3 successfully using the following modules and settings:
module purge
module load intel/2020.2
module load impi/2020.2
module load pnetcdf/1.11.2
module load netcdf/4.6.1
module load hdf5/1.10.6

Yet I ran into a problem when running real.exe. The error says "REAL: error opening wrfinput for writing". I did some web searching and learned that the most common reason for this error is that the model was not built with large file support. This is not my case. I can ran WRFV4.2 with the same namelist.input and met*.nc files. Please see attached for the namelist.input, met*.nc file, and rsl files. Hope I can get help here on how to solve this problem.


    34.4 MB · Views: 51
Hi chenhua,
I am sorry to answer so late. Somehow this post was skipped and we are not aware it was never addressed.
Please let me know whether you ahem solved this issue. If not, let's try the opitons below:
(1) set max_dom =1 and let me know whether you get the same error message.
(2) If max_dm =1 works, then let's try to set
max_dom = 2
specified = .true., .false.,
(3) Please set
I am suspicious that the io_form = 11 might cause the issue you have, but I am not 100% sure.
Please keep me updated about this case. Thanks.