Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Real.exe claims NUM_LAND_CAT = 0 but untrue

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

jamesrup

New member
Hi WRFHelp community,

I'm having this problem with WRF3.9.1.1 (and using the corresponding version of WPS), running on Texas A&M TACC Stampede2.

I'm having an issue in trying to generate ICs and BCs for a single domain from GFS 0.25 analysis and forecast files from this dataset: https://rda.ucar.edu/datasets/ds084.1/

I run WPS and get met_em_d* files with no issue, and can verify that NUM_LAND_CAT = 21 both in these files and in my WRF namelist.input and namelist.output (attached). But when I run real.exe it crashes with the below error, which is duplicated in a couple of my rsl.out files. Any ideas?

As for WPS, I didn't add anything special to the default namelist.wps (attached), and simply used the default Vtable.GFS.

Thanks for any help!
James


Domain 1: Current date being processed: 2017-09-15_12:00:00.0000, which is loop # 1 out of 4
configflags%julyr, %julday, %gmt: 2017 258 12.00000
d01 2017-09-15_12:00:00 med_sidata_input: calling open_r_dataset for met_em.d<domain>.<date>
d01 2017-09-15_12:00:00 med_sidata_input: calling input_auxinput1
metgrid input_wrf.F first_date_input = 2017-09-15_12:00:00
metgrid input_wrf.F first_date_nml = 2017-09-15_12:00:00
d01 2017-09-15_12:00:00 mminlu = 'MODIFIED_IGBP_MODIS_NOAH'
----------------- ERROR -------------------
namelist : NUM_LAND_CAT = 0
input files : NUM_LAND_CAT = 21 (from geogrid selections).
d01 2017-09-15_12:00:00 ---- ERROR: Mismatch between namelist and wrf input files for dimension NUM_LAND_CAT
NOTE: 1 namelist vs input data inconsistencies found.
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 1142
NOTE: Please check and reset these options
-------------------------------------------
 

Attachments

  • namelist.input
    4.4 KB · Views: 69
  • namelist.output.txt
    82.6 KB · Views: 44
  • namelist.wps
    1.4 KB · Views: 67
  • rsl.out.0010.txt
    3.2 KB · Views: 52
Hi James,
This is odd. This wouldn't have anything to do with your input data, so you don't have to worry about that. The num_land_cat parameter comes from your geogrid static data landuse, which if you're using the default option, it is MODIS, which has 21 categories. Can you issue the following command in your WRF running directory:

ls -ls >& ls.txt

and attach that ls.txt file? Can you also attach your compile log and your configure.wrf log? Searching through older emails, it seems that someone else running on a large university cluster had a similar problem. I'd like to see if your set-up is similar.

Thanks,
Kelly
 
Hi Kelly,

Thanks a lot for your reply. Here are the three files you requested. That would be great if it's unrelated to the output, which is as I would expect given that these GFS files are up-to-date from NOAA.

Cheers,
James
 

Attachments

  • configure.wrf
    23.1 KB · Views: 48
  • ls.txt
    33.5 KB · Views: 59
  • compile.out.txt
    716 KB · Views: 45
James,

Okay, the other person was also having a problem with Intel V17.0.4. They proposed a fix that worked to solve their problem. I'm attaching a file for you to try. Can you place this in your WRFV3/main/ directory and then recompile the code? You shouldn't need to clean or reconfigure. Just simply recompile. After that, run it again and see if it makes any difference.

Thanks,
Kelly
 

Attachments

  • real_em.F
    64.8 KB · Views: 178
Kelly,

Amazing, that innocent little extra line in the new real_em.F did the trick! REAL.exe ran with no problems, and produced the input files!

Thank you for your help with this! I'll make sure to hang onto this revised real_em.F for future compilations.

Thanks again!
James
 
Top