Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Real.exe - ERROR opening wrfinput_d02 for reading ierr= -1021

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi all,
I compile WRF-ARW v. 4.0. All OK, but When I run real.exe I have the same error:

d01 2016-04-01_00:00:00 alloc_space_field: domain 2 , 7960576 bytes allocated
d01 2016-04-01_00:00:00 alloc_space_field: domain 2 , 58074188 bytes allocated
d01 2016-04-01_00:00:00 *** Initializing nest domain # 2 from an input file. ***
-------------- FATAL CALLED ---------------
program wrf: error opening wrfinput_d02 for reading ierr= -1021

Thank you in advance for your reply.

I update files.


  • namelist.input
    1.7 KB · Views: 37
  • namelist.wps
    1.3 KB · Views: 35
Your namelist.input and namelist.wps look fine. I just wonder whether you have run REAL successfully? Please double heck whether you have all three wrfinput files existing in your working directory.
Please also try the latest version of WRFV4.2.1 and let me know whether you still have the same issue. thanks.