Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Real.exe issues NetCDF error: NetCDF: HDF error


New member
Hi all,

I have same setup ran successfully previously on Cheyenne, and now not running on Derecho. I have generated the met_em* files and trying to run real.exe and got this error.

This is the path on Derecho


d01 2012-04-01_00:00:00 calling med_sidata_input
d01 2012-04-01_00:00:00 med_sidata_input: calling open_r_dataset for met_em.d<domain>.<date>
d01 2012-04-01_00:00:00 NetCDF error: NetCDF: HDF error
d01 2012-04-01_00:00:00 NetCDF error in wrf_io.F90, line 1077
-------------- FATAL CALLED ---------------
error opening for input; bad date in namelist or file not in directory
MPICH ERROR [Rank 0] [job id ] [Tue Jan 30 08:29:14 2024] [derecho2] - Abort(1) (rank 0 in comm 0): application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
I believe there is something wrong with the file. If I go to your WPS directory and do a full listing on the met_em* files, I can see this:

 1004 -rw-r--r-- 1 achugbu ncar 26794481 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26140 -rw-r--r-- 1 achugbu ncar 26766653 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26136 -rw-r--r-- 1 achugbu ncar 26759952 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26136 -rw-r--r-- 1 achugbu ncar 26759961 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26180 -rw-r--r-- 1 achugbu ncar 26805259 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26188 -rw-r--r-- 1 achugbu ncar 26815839 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26184 -rw-r--r-- 1 achugbu ncar 26811070 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/
26192 -rw-r--r-- 1 achugbu ncar 26818194 Jan 28 14:21 /glade/derecho/scratch/achugbu/Nebraska/NEW_SIM/WPS/

As you can see, the first file is much smaller than all the others. I ran a real.exe test with a namelist that started with 2012-04-01_00 and got the same error as you, but if I set the start time to 3 hours later, it runs fine.

Thanks Kwerner, the simulation runs fine too when I jump the first met_em* file. Just wandering why is ridiculously smaller than others. Thanks.

I'm not really sure. Can you try to reprocess just that single time (2012-04-01_00:00:00) with metgrid and see if the file size looks better?