Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

real.exe segmentation fault 11 - ERA5-pressure-level data

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
hello all,
I am very new to WRF and trying to use ERA5-pressure-level data to simulate a hurricane event.
Following the tutorial here .
I got the following files for pressure level and surf data for the period I am interested in.

- geogrid.exe runs fine and I can visualize my nested domains.
- ungrib.exe

below is what I am doing and I wonder if it's the correct way of doing it:

./link_grib.csh /ERA5-20180911-20180919-pl.grib
before running ungrib.exe, I edit the lines:
out_format = 'WPS',
prefix = 'PRES'

./link_grib.csh /ERA5-20180911-20180919-surf.grib
before running ungrib.exe, I edit the lines:
out_format = 'WPS',
prefix = 'SURF'

I end up with PRES* and SURF* for all timesteps. Then I run ./metgrid.exe with the &metgrid file prefixes as below (feeding both SURF and PRES file to metgrid):
fg_name = 'SURF','PRES'
io_form_metgrid = 2

I get all met_em files (all timesteps for d01 and first timestep for d02), link them to WRF/run folder.

Next, I am running real.exe with:
mpiexec -np 1 ./real.exe

and I get a segmentation fault 11 error - I do not see a spike in RAM usage so I don't think it's a "not enough RAM" issue.

I would really appreciate any advice on how to proceed. I attached bunch of files that can help.

Please note that I repeated the same process with:
./link_grib.csh /ERA5-20180911-20180919-
where GRIBFILEAAA and GRIBFILEBBB were created and ran successfully with metgrid.exe - getting the same error with real.exe though.


  • configure.wps
    3.3 KB · Views: 14
  • namelist.wps
    734 bytes · Views: 16
  • metgrid.log
    4.6 MB · Views: 13
  • namelist.input
    3.7 KB · Views: 16
  • rsl.error.txt
    2.9 KB · Views: 14
  • rsl.out.txt
    16 KB · Views: 14
It sounds like you're running the WPS process correctly, but you may not be using all the data you are supposed to. Take a look at this page to learn about using the invariant file.

As for the seg-fault, there are many different reasons that could be happening. Perhaps it could be related to the input data, or it could also be a disk space issue. Check to make sure you have enough space on your disk to write the output from running real.exe.
Hi Kelly,

thanks for your answer.

Just to help others who may have a similar problem, here is what I did (Specifically for ppl downloading ERA5 data directly from Copernicus):

1) When downloading the surface level data, do not include the variable "land_sea_mask" - it conflicts with WRF's land sea mask. ERA5 data hosted on NCAR's Research Data Archive (RDA) does not have "land_sea_mask" variable.
2) ./link_grib.csh ./WRF_Data/external/ERA5- (note that this folder has ERA5-xxxxx-surf.grib AND ERA5-xxxxx-pl.grib)
3) ln -sf ungrib/Variable_Tables/Vtable.ECMWF Vtable (Vtable.ECMWF is identical to
4) ungrib.exe
5) metgrid.exe
in the namelist.wps, add:
constants_name = '/path_to/WPS/ERA5_INVARIANT',

6) real.exe then wrf.exe as usual.

Segmentation fault was probably irrelevant. Changed back to GNU compilers and it seems to be working fine so far. I will revisit the intel compilation later.