Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

real exe stops running

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Hi WRF team. I am encountering an error when running real.exe. rsl.error shows this before the real stops running

 Nesting domain
 ids,ide,jds,jde            1         511           1         656
 ims,ime,jms,jme           -4         265          -4         340
 ips,ipe,jps,jpe            1         255           1         328
 ids,ide,jds,jde           37         144          32         168
 ims,ime,jms,jme           32          99          27         109
 ips,ipe,jps,jpe           35          89          30          99
d03 2018-11-30_06:00:00  alloc_space_field: domain            4 ,              43503952  bytes allocated

I have four domains. wrfbdy and wrfinput1,2,3 are produced, but nothing for wrfinput4. I checked the disk size, but there is still 100gb left and I have configured WRF for large file. I am using WRF3.9.1.I am attaching relevant files for your reference. Thanks.


  • rsl.error.tar
    917.5 KB · Views: 56
  • configure.wrf
    20.3 KB · Views: 54
The namelist.wps file that you sent in the tar file only has 3 domains, while namelist.input has 4. They also have different dates. Can you attach the correct namelist.wps file that should be used with the particular WRF run? Thanks!
Hi. My apologies. I thought I attached the right namelist.wps. Please see attached for the new one. THank you so much


  • namelist.wps
    1.8 KB · Views: 56
I can't say for sure, but the problem could potentially be that the file size for the wrfinput_d04 file is just much larger than the other 3 domains. Even if you have large file support, there is still a 4 GB limit on the file size. I'm not sure how large the file would be, but your d04 is substantially larger than the others. Because the size is so large AND it's using a 5:1 ratio, it's ~41x the size of d03. Can you check to see how large the wrfinput_d03 file is and see how large that would make d04? You'll also want to make sure the d03 file is complete.
Hi. Upon checking wrfinput_d03, the size is 107.6. Multiplying it by 41 would make _d04 4.4gb. Do I have to increase the horizontal resolution of the _d01 then? Thank you for your advice.
Increasing the size of d01 will not help in this scenario. The problem is likely due to a NetCDF limitation of 4 GB files to be written to your directory. This is not related to WRF or your system. What you may need to do is to run real.exe in increments, splitting up the time so that the files will be smaller. Take a look at this previous forum post:
Look at my response on Nov 4th, in which I explain how to do this. Perhaps that will be a solution for you, as well.
I tried running real.exe like what you said. I encountered a problem though. Even if I run it at < 5 days, the same error appears. wrfinput_d03 produces the same file size regardless if I decrease the run time.
Ah, yes - that is because it's only an initial condition file, so the dates/times don't matter. I definitely should have realized that. I apologize for leading you down the wrong path with that.

So another thing you can try is to use the split netcdf option. In your namelist, you would need to set:
io_form_history = 102
io_form_boundary = 102
io_form_input = 102

This will split the wrinput/wrfbdy files into multiple files - 1 per processor. You then will run wrf with the same number of processors, and you have set the history files to also be output in the split netcdf format. Once you do that, you can use a script to patch the tiles back together, which you can find here:
(Take a look at the Joiner code)