Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

real.exe V4.0 Error

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


i am having problems running real.exe from WRF4.0.
i have been using WRF successfully. i then tried WRF4.0 - Both versions were built on a linux CentOs7 machine using ifort and dmpar
i am using the same namelist.wps, namelist.input and imput data (ERA Interim) in both and 4.0
i also downloaded the new geog static data

WPS4.0: geogrid, ungrib and metgrid run fine
WRF 4.0: real.exe crashes right at the beginning with this message:

taskid: 0 hostname:
module_io_quilt_old.F 2931 T
Ntasks in X 1, ntasks in Y 1
Parent domain
ids,ide,jds,jde 1 75 1 85
ims,ime,jms,jme -4 80 -4 90
ips,ipe,jps,jpe 1 75 1 85
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1, 395303496 bytes allocated
d01 2011-05-01_00:00:00 Yes, this special data is acceptable to use: OUTPUT FROM METGRID V4.0
d01 2011-05-01_00:00:00 Input data is acceptable to use:
metgrid input_wrf.F first_date_input = 2011-05-01_00:00:00
metgrid input_wrf.F first_date_nml = 2011-05-01_00:00:00
d01 2011-05-01_00:00:00 Timing for input 1 s.
d01 2011-05-01_00:00:00 flag_soil_layers read from met_em file is 1
Max map factor in domain 1 = 1.19. Scale the dt in the model accordingly.
Using sfcprs3 to compute psfc
d01 2011-05-01_00:00:00 No average surface temperature for use with inland lakes
Assume Noah LSM input
d01 2011-05-01_00:00:00 Timing for processing 6 s.
forrtl: error (73): floating divide by zero
Image PC Routine Line Source
real.exe 000000000F6AE901 Unknown Unknown Unknown
real.exe 000000000F6ACDB7 Unknown Unknown Unknown
real.exe 000000000F656064 Unknown Unknown Unknown
real.exe 000000000F655E76 Unknown Unknown Unknown
real.exe 000000000F5EC4A6 Unknown Unknown Unknown
real.exe 000000000F5F410F Unknown Unknown Unknown 00002B2A10A306D0 Unknown Unknown Unknown 00002B2A0FCC7709 Unknown Unknown Unknown 00002B2A0FCC5F19 Unknown Unknown Unknown 00002B2A0FCB9E9D Unknown Unknown Unknown 00002B2A0FCB9DE3 Unknown Unknown Unknown 00002B2A0FC45E80 Unknown Unknown Unknown 00002B2A0F743DC4 Unknown Unknown Unknown
real.exe 000000000F47054B ext_ncd_open_for_ 1986 wrf_io.f
real.exe 000000000127B7F0 module_io_mp_wrf_ 18443 module_io.f90
real.exe 0000000003BBF544 module_io_domain_ 58 module_io_domain.f90
real.exe 000000000041A265 assemble_output_ 695 real_em.f90
real.exe 0000000000411884 med_sidata_input_ 470 real_em.f90
real.exe 000000000040EA2E MAIN__ 242 real_em.f90
real.exe 000000000040CB0E Unknown Unknown Unknown 00002B2A10E6B445 Unknown Unknown Unknown
real.exe 000000000040CA11 Unknown Unknown Unknown

any ideas are greatly appreciated, thanks!

Charles Jones
Hi Charles,

I moved your post to it's own topic because I don't think your problem is related to any of the others discussed in the other topic.
Can you please provide the following:

1) namelist.wps for both and 4.0
2) namelist.input for both and 4.0
3) your full error/out log file (if you have rsl.* files, please package those together into 1 *.tar file and attach that)

Thanks for sending those. I also looked at your directory on Cheyenne and used your met_em* files and namelist.input file to try the run, myself, using the default pre-compiled WRFV4.0 code. I am able to run real.exe without any problems. Did you make any modifications to the default code?

Did you use the default pre-compiled code in Cheyenne, or did you make any changes to the code, and have to re-compile before running this?

i compiled the code on cheyenne using configure -D and selecting option 15 - the same on my local machines.

Hi Charles,

I was able to repeat this problem with a basic namelist set-up, so this doesn't seem to be particular to your simulation. I was able to narrow it down to being a problem with some combination of netCDF V4.6.1, an Intel processor, and the real.exe program, when configure -D (debugging) is used during to compile. I ran the same case without debugging, and it worked fine. I ran with a different version of netCDF and with a GNU compiler, and it also worked fine. So there are currently 2 work-arounds:

1) You can use a different compiler and version of netCDF.

2) You can run real.exe without turning on debugging/no-optimization (i.e., just ./configure), and then if you need the additional debugging for your WRF simulation, you can recompile the code with configure -D after real.exe runs successfully.