Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) Compile errors (Dummy argument ‘datasetname’)

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi! I have followed the compilation tutorials and set the environment variables. Environment and compatibility tests are successful. I am still encountering fatal errors leading to failure to build needed modules and therefore, executables. I tried the workarounds the other threads suggested including J='-j 1', doing ./clean -a, and recompiling the code but to no avail.

I am using the latest GNU compiler and libraries.

I am attaching my compile log and configure file. Please let me know how to solve the errors. Thank you very much.


  • configure.wrf
    20.3 KB · Views: 35
  • compile.log
    1.4 MB · Views: 38
Have you made modifications to the WRF code, or is this unmodified "out-of-the-box" WRF code?
I am the same user. I created a new account because I am getting HTTP 500 Internal Server Error and already contacted the admin about it.

I did not make any modifications to the WRF code.
I already solved the error. I used WRF4.0 with GNU10. The solution was a combination of compiler flags, revision of configure.wrf, landread.c and allotting more memory.
That is great news! I'm so glad to hear that, and I'm sorry you were having trouble with your old user name. Thank you for updating the post.