Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) ERA5 data: awkward snow and soil moisture values

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have been using WRF3.9.1 with ERA5 data and I have found out that some of the fields
do not seem to be interpolated well. I have noticed that with sea ice which we solved by
changing the interp_option in METGRID.TBL to


However the soil moisture also behaves awkwardly, as I have some negative values there
(see enclosed figure). I tried to change the interp_option to various combination, as described
in ARWUsersGuideV3.9, but there never were only positive values.

Obviously, this causes the Flerchinger error (
So I wondered if someone had a similar problem and knows how to solve it? ronbeag in the post above
suggested editing wrf_input files with ncl to set all negative values to 0.05, but I cannot quite grip ncl
so I am not sure how I would write such a script. :(

Furthermore, the snow height also has very ackward gradients (again I enclose figure). That I was also trying
to solve a little bit with interp_option in METGRID.TBL, but as it is not explained in the ARWUsersGuideV3.9 what does each interpolation
mean, it is difficult to decide which combinations might make sense.

Now I think it might also be a problem already from ungrib, so I am sorry, if I did put it into a wrong forum.

Anyway, thank you for any suggestions.


  • Soil_moisture2.JPG
    137.1 KB · Views: 1,160
  • Snow_height1.JPG
    127.9 KB · Views: 1,160
Would you please send me your namelist.wps to take a look? I suppose you download ERA5 data from CISL website. Please let me know if I am wrong. Please also le the know which Vtable you use to ungrib the ERA5 data. Thanks.

thank you very much for having a look at my problem.

I am enclosing namelist. wps and I download ERA5 data via 2 Python scripts, which I also enclose.

It was not possible to attach the Vtable, but it is from WRF3.9.1.

Thank you for any answer.


    1.1 KB · Views: 53
    1.1 KB · Views: 53
  • namelist.wps
    1.5 KB · Views: 58
I apologize for answering so late. This is because I spent some time to thoroughly explore the ERA5 data (soil levels, landmask, etc.)
I repeated your case based on the namelist.wps you sent me. It seems that the domain in my case is different from yours, but I do get negative soil moisture at some points.
We are looking at this issue and I will get back to you once we find a solution. Thanks for your patience.

I wonder whether you have downloaded the following two invariant data:

e5.oper.invariant.128_172_lsm.regn320sc.2016010100_2016010100.grb (land-sea mask)
e5.oper.invariant.128_129_z.regn320sc.2016010100_2016010100.grb (terrain geopotential, m2/s2)

If not, please download them and ungrib them separately to produce CONST files for landmask and terrain height. Then run metgrid.exe again.

I found that if I don't include the above information, then I get negative soil moisture at some points. If the landmarks information is available, then everything looks fine.
Hello Ming Chen,

thank you very much for the enquiry and the advice, using these two invariant fields, indeed, helped.

Just a last question from a newbie to WRF:
I checked this page (
and it seemed to me that using ERA5, the land-sea mask and terrain geopotential are the only two invariant field that I need.
Is that right?

Once again,
thanks a lot for the help.