Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) Error:Could not open /Build_WRF/DATA/WPS_GEOG/modis_landuse_21class_30s/index

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am trying to run WRF-chem with dust simulation and I linked ln -svf GEOGRID.TBL.ARW_CHEM GEOGRID.TBL in geogrid dir.
When I am running geogrid.exe, I am getting the following error
ERROR: Could not open/Build_WRF/DATA/WPS_GEOG/modis_landuse_21class_30s/index
application called MPI_Abort(MPI_COMM_WORLD, 60697904) - process 0

I tried to look for modis_landuse_21class_30s data and I couldn't find in the static data download page.

Am I missing some data ? (Apart from the mandatory fields data and Thompson MP Scheme (mp_physics=28) and chem data)

Please Help!

thanks, Prerita
Hi Prerita,
In your namelist.wps file, are you using the full path to your geographic static data for the parameter "geog_data_path?" Based on the error, it looks like you are setting it to:
If that is not the full path, can you try setting it to the full path and see if that makes a difference? If not, please attach your namelist.wps file and your geogrid.log file. Please also let me know which version of WPS you are using. Thanks!
Thanks for the reply.
I found the solution to the error.
I was using the WPS_GEOG data (highest resolution of each mandatory field) with WPS version 4.1 for running WRF.
When I linked GEOGRID.TBL.ARW_CHEM GEOGRID.TBL the aforementioned error was thrown. It was resolved when I downloaded the older 'complete_dataset' and ran geogrid.

However, it solved the issue but is there any way to use the latest static data with GEOGRID.TBL.ARW_CHEM

Thanks, Prerita
I assume that you tried the new 'complete dataset' with the "GEOGRID.TBL.ARW_CHEM" table, and still received the error?
Can you please attach the namelist.wps file just so that I can see what your settings are before telling you what to modify in the chem geogrid tbl? Thanks!
Thanks for sending that. I am able to repeat the error only when I'm using the low-resolution static data. When I use the full dataset, I don't get any errors. To be sure, are you using the download from this site?

If not, make sure you have that latest data set.
In order to make the GEOGRID.TBL.ARW_CHEM work with the low resolution dataset, you'll need to modify it to add all the "lowres" lines in it. Take a look at the standard GEOGRID.TBL.ARW file to see what these lines should look like.
I am having a similar issue. I have downloaded the geog_high_res_mandatory zip file from the website. I have attached the namelist.wps file which is from Micheal Duda winter WRF tutorial 2020. I had soft linked GEOGRID.TBL.ARW to GEOGRID.TBL
Here is the error I got:
Parsed 25 entries in GEOGRID.TBL
Processing domain 1 of 1
ERROR: Could not open /newhome/rc13564/Build_WRF/WPS_GEOG/modis_landuse_21class_30s/index
I also could not find the modis_landuse_21class_30s folder when I looked up the static data folder WPS_GEOG. Any help would be really appreciated


  • namelist.wps
    415 bytes · Views: 154
Hi Rabi,
Can you let me know which version of WPS you are using, and also attach the geogrid.log and the GEOGRID.TBL file you are using? Thanks!
With the v3.9 release of the WPS (in April 2017), we switched the default land use dataset in the GEOGRID.TBL.ARW file; see WPS PR #25. Prior to that release, the default land use data was read from a directory named 'modis_landuse_21class_30s', while the current default data comes from a directory named 'modis_landuse_20class_30s_with_lakes'.

If you happen to be working with a release of the WPS before v3.9 (or if you are using an old GEOGRID.TBL.ARW file with the current release of the WPS), you can download the old static datasets from the v3 geographical data download page.
I am using WPS v3.8 now. I downloaded the Complete Dataset from the web link suggested which worked successfully.

Thanks much for the help! Rabi

I'm facing a very similar problem. When executing ./geogrid.exe the next error is displayed:

Parsed 29 entries in GEOGRID.TBL
Processing domain 1 of 1
ERROR: Could not open home/maria/Desktop/Build_WRF/WPS_GEOG/topo_gmted2010_30s/index
application called MPI_Abort(MPI_COMM_WORLD, 22098) - process 0

I'm using the 4.0 WPS version and here I attach the namelist.wps file in a .txt format.
View attachment namelist.wps.txt

Also, I downloaded the Highest Resolution of the Mandatory Static data from this link:

Thanks in advance.


I found the error in the namelist.wps file, I was missing a / at the beginning of the geog_data_path. It worked as follows with the / at the beginning and the end of the path:

geog_data_path = '/home/maria/Desktop/Build_WRF/WPS_GEOG/'