Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) "Error in ext_pkg_open_for_write_begin"

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi everyone,

I am facing a problem with metgrid recently. When running 'metgrid.exe' for 2018. no matter what resolution of grib2 files I use, I get an error immediately that says:

"Processing domain 1 of 1
Processing 2018-07-01_00
ERROR: Error in ext_pkg_open_for_write_begin."

However, I did not get this error when I ran it for 2014.

I am kind of stuck here and I cannot find anything helpful online. So, I would appreciate any help from your side.


I use the 6 hourly, 0.25 degree grib2 data from RDA website:
I only use the "*.f00.grib2" data since I am not working on forecast.

About the comparison, I am actually not sure how to compare them! Do we use wgrib2 for that?

Thanks for the help!
Actually, it just ran successfully! For some reason it could not find the folder I had defined in namelist.wps for metgrid outputs!
I deleted and created the folder again and it solved the problem!

Sorry for taking your time for this!