Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) g2print.exe output differs from wgrib2 with ERA5 data

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


I am running WRFv4.0, and using grib2 files containing ERA5 model level data (137 levels) for 48 hour time period with 1 h time step. The data are in one file which is in grib2 format. The g2print.exe extracts the model level data only for the first hour (00). However, when I apply wgrib2, the data are successfully extracted for all the time periods (48 hour).

And it's not just a problem with how g2print is reading this file; if I run ungrib with my grib2 data I get the following error:

Subroutine DATINT: Interpolating 3-d files to fill in any missing data...
Looking for data at time 2018-08-10_00
Found file: era5_ml:2018-08-10_00
Looking for data at time 2018-08-10_01
ERROR: Data not found: 2018-08-10_01:00:00.0000

When I convert my input grib2 data to grib1 format through grib_set command the g1print.exe successfully shows my data from 1 to 48 h, and the ungrib.exe works with the grib1 data.


We are aware of the issues related to ERA5 data. Please take a look at the post here to see whether it is helpful for you.
I would like to inform you that I also tried to download the ERA5 model level data on reduced Gaussian grid as mentioned in the post suggested by you. Since the ERA5 model level global fields were too big, I had to download first temperature and u wind in one file, and specific humidity and v wind in the other grib2 file.

The g2print.exe again extracts grib2 data only for the first time step (g2print.txt), and ungrib.exe fails to work (ungrib_g2.log) with my Vtable (Vtable.grib2)
The g1print.exe program successfully extracts my grib1 converted data (g1print.txt), but the ungrib.exe fails to work (ungrib_grib1.error and ungrib.log). I use the standard file with my grib1 data.



  • ERA5_ERRORS.tar.gz
    67.7 KB · Views: 47
WPS can process GRIB1 format datafile that contains multiple times of data. However, for GRIB2 format, WPS can only process datafile that contains a single time data.
You need to either convert the data to GRIB1 format, or split multi-time data to separate single-time files.