Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) Geogrid error: Fortran runtime error: End of record

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

fpolicel

New member
Hello,
I am getting the error below when I run geogrid. Attached are my geogrid.log and my namelist.wps files. Please advise on best solution.
Fritz

Parsed 28 entries in GEOGRID.TBL
At line 487 of file source_data_module.f90
Fortran runtime error: End of record

Error termination. Backtrace:
#0 0x2aaaaae28bdc in formatted_transfer_scalar_write
at /gpfsm/dnbsrc/other/GCC/SLES11/7.3/gcc-7.3.0/libgfortran/io/transfer.c:2059
#1 0x2aaaaae28d7c in formatted_transfer
at /gpfsm/dnbsrc/other/GCC/SLES11/7.3/gcc-7.3.0/libgfortran/io/transfer.c:2279
#2 0x45adab in ???
#3 0x4035c8 in ???
#4 0x2aaaab7a7c35 in ???
#5 0x4025b4 in ???
at ../sysdeps/x86_64/elf/start.S:113
 

Attachments

  • geogrid.log
    4.3 KB · Views: 58
  • namelist.wps
    1.4 KB · Views: 65
Hi,
Can you also attach the file /geogrid/src/source_data_module.f90? Please also let me know which version of WPS you are using. Thanks!
 
According to the README file, I am using version 4.1. Attached is my source_data_module.f90 file.
Thank you for your help,
Fritz
 

Attachments

  • source_data_module.f90
    147.6 KB · Views: 62
Hi,
I solved the problem. I had the wrong path for the geographic input data. You can close this posting.
Thank you,
Fritz
 
Top