Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) geogrid error: unable to open index file for static data path

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.

Akinleye

New member
Hi.....I've been trying to run the geogrid.exe for sometimes now, but wouldn't access the index file.

--------------------------------------------------------------------------------
Parsed 28 entries in GEOGRID.TBL
Processing domain 1 of 2
ERROR: Could not open /Build_WRF/WPS_GEOG/topo_gmted2010_5m/index
------------------------------------------------------------------------------------------

Could you please help me with it.....Attached here is the geogrid.log and the namelist.wps.

Thanks
 

Attachments

  • geogrid.log
    4.5 KB · Views: 68
  • namelist.wps
    1.3 KB · Views: 77
Hi,
Can you issue this command in your /Build_WRF/WPS_GEOG/ directory:
ls -ls >& geog.txt
and send that geog.txt file? Thanks!
 
It's worth noting that the path to the static, geographical datasets that is given in the "geog_data_path" namelist option should be the absolute path to the data. Is it the case that the "/Build_WRF/WPS_GEOG/" directory is not actually at the root of the filesystem, but is actually a subdirectory of, e.g., your home directory?
 
@mgduda, I agree with you thats its in the subdirectory under Home, but i don't think that should affect it. I tried to change the path but similar issue remains. Thanks
 
I just noticed in the error message that geogrid is looking for an index file in the topo_gmted2010_5m directory. In the table on the geographical download page (http://www2.mmm.ucar.edu/wrf/users/download/get_sources_wps_geog.html) it's mentioned that the download for the highest resolution data only contains the topo_gmted2010_30s dataset. In order to get the topo_gmted2010_5m dataset, you'd need to download the lowest resolution data.

Alternatively, using
Code:
geog_data_res = 'default',
in your namelist.wps file should instruct geogrid to look for the topo_gmted2010_30s dataset, which you already have.
 
Yeah, you are right.. Actually, it was in the process of trying to bypass the error message with the topo_gmted2010_30s that i instead tried the 5m, perhaps it had work. my present namelist.wps reads

geog_data_res = 'default','default',
 
Top