Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) map_utils_module.f syntax compiling error of OBSGRID

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I tried to re-compiled the OBSGRID due to the update of the Linux OS. WRF and WPS were successfully compiled with ifort and icc 19.1.1 and related netCDF library. When I tried to compile OBSGRID, the follow error shows

**** Compiling oa ****

/bin/rm -f map_utils_module.o map_utils_module.mod
/lib/cpp -I. -C -P -DDEC -traditional map_utils_module.F90 > map_utils_module.f
ifort -FR -convert big_endian -c map_utils_module.f -I/lustre/haohe/CMAQv5.3.1/lib/netcdf/include
map_utils_module.f(1): error #5082: Syntax error, found '/' when expecting one of: <LABEL> <END-OF-STATEMENT> ; <IDENTIFIER> TYPE MODULE ELEMENTAL IMPURE NO$
/* Copyright (C) 1991-2018 Free Software Foundation, Inc.

I search it on-line, it is related to the free format. I didn't meet this problem in the old OS. So I think something new could cause this error. Attached please find my configure.oa. Any comments or suggestions are highly appreicated.



  • configure.oa.txt
    1.7 KB · Views: 60