Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) NetCDF 3 output when running WRF 4.3

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I have been running WRF 4.2 in an Ubuntu LTS box without any issues. Recently I tried updating to WRF & WPS 4.3, which compiled successfully and runs without problems. However, it outputs NetCDF 3 (old format) files instead of NetCDF/HDF5. I have tried changing the configure.wrf file in several ways and recompiling, but the issue continues. Output files are NetCDF3. WRF 4.2 creates NetCDF/HDF5 files as expected.
Can someone please guide me at to where I should be looking to solve the issue? I am attaching configure.wrf and the output of nc-config.


  • configure.wrf
    20.4 KB · Views: 26
  • nconfig.txt
    1.3 KB · Views: 27
It's likely that when you compiled WRFV4.2, you had your netcdf path pointing to a netcdf that was built with the version 4 features, and perhaps the path has changed since then. You could compare your configure.wrf files from your WRFV4.2 and WRFV4.3 builds to see if there is an obvious difference. If you're unable to figure it out, you'll need to speak to a systems administrator at your institution to inquire about the correct location and then make sure you have your PATH and NETCDF environment variables set to the correct version of netcdf.
I am the administrator of the machine and I did compare the two configure files. That for some strange reason didn't work. However, I did manage to properly compile WRF so that it creates HDF5 files. I am attaching the successful configuration file, for what its worth.


  • configure.wrf
    20.6 KB · Views: 56
I'm so glad to hear that you were able to get it working. Thank you for updating the post, and for sharing your configure file.