Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) No executables- WRF Model Version 4.2.2 Compiling

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi guys,

I tried to compile the WRF using "./compile em_real >& log.compile && ls -ls main/*.exe" command and got an error massage as "ls: cannot access 'main/*.exe': No such file or directory".

Next, I checked the log.compile file and the following error was in the log.compile file
---> Problems building executables, look for errors in the build log <---

Then I tried to find the first Error inside the log.compile file and I couldn't find the Error.[/b][/b][/b]

Please help me


  • configure.wrf.txt
    20.3 KB · Views: 52
  • log.compile.txt
    868 KB · Views: 72
Can you do the following steps:
  • ./clean -a
  • setenv J "-j 1"
(or if you're using bash, export J="-j 1")
  • ./configure
  • ./compile em_real >& log.compile

and then send the new log.compile file and configure.wrf? Thanks!
Dear Kwerner,

Thank you for quick respond and sorry for my delay. As you mentioned, I re ran the programme as,

./clean -a
export J="-j 1"
./compile em_real >& log.compile

But no executables in the main directory this time also. I have attached new log.compile file and configure.wrf file to check and get your comments.


  • configure.wrf.txt
    20.3 KB · Views: 47
  • log.compile.txt
    988.3 KB · Views: 58
Thanks for sending those. If you haven't already, can you go through this page from the beginning, to ensure that your environment is set-up correctly and that your compilers and libraries are all compatible with each other? Although you likely already have your libraries built, I would suggest rebuilding them, based on the instructions in this guide. This will help to ensure better success. Let me know what happens after that!
I rebuilt the libraries and performed tests which are mentioned in the Then I was able to successfully compile the WRF programme with the relevant executables without any problem.

Thank you for your comments.
The culprit was Ubuntu.. I reinstalled Ubuntu, reinstalled library and recompiled without error. I'll run the test model now. Thanks everyone for the support.