Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) problem with multiple geog_data_res resolutions

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hi all...

I'm having a problem with geogrid under WPS-4.1. I have a 3s topography dataset that I use for grids with 1km resolution or finer. It has worked fine for several years on previous versions.

What I'm seeing now is that if in my geog_data_res listing it goes from 'default' for the coarse grids, to 'gtopo_3s' to the fine grids it works ok. But if I then add another coarse grid, and select 'default' for that one, it appears to run without error, but HGT_M is set to zero everywhere within that domain.

Here's an example that displays this problem:

parent_id = 1,1,2,3,3,3,3,2
parent_grid_ratio = 1,3,3,3,3,3,3,3
i_parent_start = 1,31,48,172,213,310,385,262
j_parent_start = 1,23,52,456,206,94,38,87
s_we = 1,1,1,1,1,1,1,1
e_we = 268,622,592,541,220,220,232,235
s_sn = 1,1,1,1,1,1,1,1
e_sn = 184,418,673,367,220,220,232,274
geog_data_res = 'default','default','default','gtopo_3s','gtopo_3s','gtopo_3s','gtopo_3s','default',
dx = 27000,
dy = 27000,
map_proj = 'lambert',
ref_lat = 45.7614630743396,
ref_lon = -123.043565994056,
ref_x = 71,
ref_y = 97,
truelat1 = 30.0,
truelat2 = 60.0,
stand_lon = -123.043565994056,
geog_data_path = '/filer_data/data/wps_data'
opt_geogrid_tbl_path = './'

All of the resulting files are apparently fine, except for For d08 all values of HGT_M are zero.

On the other hand, if I use either of the following geog_data_res lines, then I get valid HGT_M data in all of the files:

geog_data_res = 'default','default','default','default','default','default','default','default',

geog_data_res = 'default','default','default','gtopo_3s','gtopo_3s','gtopo_3s','gtopo_3s','gtopo_3s',

I'd like to have the ability to use my 3s data as needed, but not when it's not needed. Any thoughts?

I don't know the reason why D08 data is wrong. Logically it should work.
Can you try a case with 2 domains, and with the folioing setting:
geog_data_res = 'gtopo_3s','default',

Let me know whether the data on D02 are correct. Thanks.
Thanks for the reply. I just gave it a try - it failed in the same way. For d02 all values of HGT_M are zero...
Also, for what it's worth, I've done a few more tests, using two much smaller domains - just to make sure there wasn't anything odd about the relatively large domains I was using.

These three versions work:
geog_data_res = 'default','default'
geog_data_res = 'gtopo_3s','gtopo_3s'
geog_data_res = 'default','gtopo_3s'

But this one does not:
geog_data_res = 'gtopo_3s','default'
Problem solved. None of the index files for all of the standard topography datasets include the "filename_digits" field. Presumably the default value is 5, which works for all of the standard topography.

But for the 3s topography, filename_digits needs to be 6 - and has been set in the index file. I haven't looked in the geogrid code, but my guess is that once filename_digits gets changed for any particular entry in geog_data_res, it will remain that value for subsequent entries - UNLESS it gets specified in the subsequent index files.

By adding a line with "filename_digits = 5" to the index file of the default topography datasets, I now get the behavior I desire.

I think I'd be inclined to call this a bug. Presumably if there is a default value for filename_digits (5), it should probably be reset between geog_data_res entries. Alternatively, maybe it should just be required to have filename_digits specified in the topography index files...