Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) Program received signal SIGSEGV: Segmentation fault - invalid memory reference

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello colleagues.

Whenever I run wrf.exe it gets this error:
Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x7f7ea2e0877d in ???
#1 0x7f7ea2e07993 in ???
#2 0x7f7ea2ad720f in ???
#3 0x55fba93f4718 in ???
#4 0x55fba93f7ec8 in ???
#5 0x55fba93fd1ac in ???
#6 0x55fba8c2bec8 in ???
#7 0x55fba8478f68 in ???
#8 0x55fba7fbe473 in ???
#9 0x55fba7ebb35f in ???
#10 0x55fba72636fe in ???
#11 0x55fba71fbcf7 in ???
#12 0x55fba71fb65e in ???
#13 0x7f7ea2ab80b2 in ???
#14 0x55fba71fb699 in ???
#15 0xffffffffffffffff in ???

I have checked my memory limits using ulimit -a, and it seems alright. Here it is:

ore file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 63251
max locked memory (kbytes, -l) 65536
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 63251
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

I request for your help on how to fix this problem.

Thank you.
Please take a look at this FAQ that discusses potential reasons for a segmentation fault and see if any of those may apply to your simulation.
Thank you for the response. It has been helpful.

I made the stacksize unlimited using this command:

ulimit -s unlimited

And everything worked well.
Great! I'm glad to hear that you were able to get past the problem. Thank you for updating the post.