Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) recipe for target 'module_stringutil.o' failed

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member

I'm trying to install WRF on my computer but I am experiencing troubles with the compilation of WPS. I am using a WSL Ubuntu.
My compilation has numerous errors that seem to be very similar. However, since I am a new user of Linux and Fortran, I have some trouble understanding what is my problem.

The error is :

Error: Invalid character in name at (1)
../../configure.wps:104: recipe for target 'module_stringutil.o' failed
make[1]: [module_stringutil.o] Error 1 (ignored)

Does anyone has already had this type of error or have an idea how to correct it ?

Thanks for your help.


  • configure.wps
    3.4 KB · Views: 51
  • log.compile
    199.9 KB · Views: 59
Please change the line below in configure.wps from

CPP = /usr/bin/cpp -P -traditional


CPP = /lib/cpp -P -nostdinc

Then type ./clean -a and rebuild WPS.

let me know whether it works.
Thank you for your answer.

I actually did what you suggested, I only performed ./clean -a before modifying the file configure.wps otherwise I noticed that making ./clean -a deleted the file configure.wps

Unfortunately I still have the initial error, and apparently additionnal ones too.

I tried to understand the error in the file module_debug.f90 but I cannot open it on my computer, the file is empty.

I attached the error file.


  • log.compile
    209.1 KB · Views: 55
I am sorry to get back to you so late, but this is because we are extremely busy recently. I just wonder whether you have solved this issue?

No problem, I didn't really solve the problem. Instead of compiling WRF into the WSL(windows subsystem for linux) I compiled it with a linux installed in dual boot. I concluded that the problem came from the WSL.