Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest


  • Thread starter Deleted member 3607
  • Start date

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


Deleted member 3607

I keep getting this error when trying to install ARWpost

Error: Type mismatch between actual argument at (1) and actual argument at (2) (INTEGER(4)/CHARACTER(*)).

I have tried installing with gcc-9 gfortran-9 with no luck either.

Any ideas?
compile log


  • namelist.ARWpost
    1.1 KB · Views: 9
  • configure.arwp
    1.7 KB · Views: 16
  • arwpost.compile.txt
    11.4 KB · Views: 12
possible solution

sed -i '32s/-ffree-form -O -fno-second-underscore -fconvert=big-endian -frecord-marker=4/-ffree-form -O -fno-second-underscore -fconvert=big-endian -frecord-marker=4 -fallow-argument-mismatch/g' configure.arwp

-fallow-argument-mismatch is not compatible with < GCC9 . So a better change is add -std=legacy
Just to confirm - the most recent post, suggesting using "-std=legacy" solved the issue? Thanks!
Yes, but I have been told that -std=legacy may remove warnings completely whereas fallow keeps them. I am going to test this out and find out if it is true. I trust stack-overflow users to be knowledgeable but I still want to test it myself