Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) unable to run WRF through gis4wrfiles of QGIS

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
Hello All,
I downloaded weather forecast from UCAR 084.1 48 hour Forecast by region for 12 hours,
When I run WRF on gis4wrfiles through QGIS, WPS and Run Real are Okay,but it unable to Run WRF ( It may run 35-45 secs and tells error for calculation.).
When I check the error from rsl.error.0000-1 that it shows like this:

Program received signal 11 (SIGSEGV): Segmentation fault.

Backtrace for this error:
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/.libs/ [0x7efc76869f59]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/.libs/ [0x7efc7686b84e]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/.libs/ [0x7efc7686a6aa]
+ /lib/x86_64-linux-gnu/ [0x7efc75eee040]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1a3b7c9]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1a56c69]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1a6ae51]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1a7a5af]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x14049dc]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1160fea]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x1059ebf]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0xfb294a]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0xed91be]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0xed9610]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x40e3ba]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x40d5af]
+ /lib/x86_64-linux-gnu/ [0x7efc75ed0bf7]
+ /home/sam/gis4wrf/dist/WRF-4.0-mpi/main/wrf.exe() [0x40d5e9]

my problem is also can find from this link:

What's wrong with it. Thanks for your kindly help.

Can you attach your namelist.input file, along with all of your running logs (e.g., rsl.error.* and rsl.out.* files)? If you have several logs, please package them together as a .TAR file (not a .rar file - we cannot open that format). Thanks!
There is a link in my post as this :
and my namelist.input:
start_year = 2021, 2021
start_month = 3, 3
start_day = 17, 17
start_hour = 0, 0
end_year = 2021, 2021
end_month = 3, 3
end_day = 17, 17
end_hour = 12, 12
interval_seconds = 21600
input_from_file = .true., .true.
history_interval = 10, 10
frames_per_outfile = 100, 100
restart = .false.
restart_interval = 7200
io_form_history = 2
io_form_restart = 2
io_form_input = 2
io_form_boundary = 2
start_minute = 0, 0
start_second = 0, 0
end_minute = 0, 0
end_second = 0, 0
nocolons = .true.

time_step = 40
time_step_fract_num = 0
time_step_fract_den = 1
max_dom = 2
e_we = 31, 31
e_sn = 31, 31
e_vert = 33, 33
p_top_requested = 5000
num_metgrid_levels = 34
num_metgrid_soil_levels = 4
dx = 2700.0, 900.0
dy = 2700.0, 900.0
grid_id = 1, 2
parent_id = 1, 1
i_parent_start = 1, 11
j_parent_start = 1, 11
parent_grid_ratio = 1, 3
parent_time_step_ratio = 1, 3
feedback = 1
smooth_option = 0

physics_suite = 'CONUS'
mp_physics = 0, 0
cu_physics = 0, 0
radt = 9, 3
bldt = 0, 0
cudt = 0, 0
icloud = 0
num_land_cat = 21
sf_urban_physics = 1, 1

hybrid_opt = 2
w_damping = 0
diff_opt = 1, 1
km_opt = 4, 4
diff_6th_opt = 0, 0, 0
diff_6th_factor = 0.12, 0.12
base_temp = 290.0
damp_opt = 3
zdamp = 5000.0, 5000.0
dampcoef = 0.2, 0.2
khdif = 0, 0
kvdif = 0, 0

spec_bdy_width = 5
specified = .true.


I am not sure what problem take place during Run WRF.

kwerner said:
Can you attach your namelist.input file, along with all of your running logs (e.g., rsl.error.* and rsl.out.* files)? If you have several logs, please package them together as a .TAR file (not a .rar file - we cannot open that format). Thanks!
I try again, it successful in half of calculation. which means I downloaded data from NCAR, and it is only run a half calculation. ( 12 hours data but output 8 hours data.)


I'm confused about the errors. In the link you shared, it looks like your error is during real.exe, "not enough info for p surface computation," but you're saying the model is running for 8 hours now? Does real.exe complete? If so, you should see a "SUCCESS" message at the bottom of your real.exe log file(s).

I also notice a few major issues with your simulation set-up.
1) You have mp_physics = 0, 0. You cannot turn off microphysics for a real data simulation.
2) Your domain sizes are 33x33. This is way too small! Your domains should be no smaller than 100x100, each. Please take a look here for guidance on best practices for setting up your domain and namelist settings.
3) I notice your parent domain has a resolution of 2.7 km. What resolution are the input data? They should not be more than about a 7:1 ratio. If they are larger, you need to have a coarser outer domain (you can add a 3rd around the current parent) to buffer the data resolution.
4) radt should be set to the same value for all domains, and should be about the same as the parent resolution. So if your outer domain is 2.7 km, you should use something like radt = 3, 3

I recommend correcting those items first, and then if it's still failing, please let me know where the failure is (real.exe or wrf.exe). When you run either real.exe or wrf.exe, you should get output and error logs. If you built WRF serially, you should use a command like:
./wrf.exe >& wrf.log
and if you built WRF for parallel computing, you should get rsl.error.* files. I need to see your error logs. Please attach those. See the home page of this forum for instructions on attaching files.
Hi kwerner,

Sorry I made confuse reply with your questionnaires.
The first post was failed during Run WRF in QGIS, and previous post was done calculation uncompleted. ( My downloaded 3 files from 20210321 0:00 to 20210321 12:00, but simulation works until 10:40am, then failed to continue calculation.) which I mean 12 hours data forecasting but calculated 10:40 hours.However,it is approval that my data basically correct and also my work on WRF is Normal.

I checked my error files as below attachments, there are some data processing wrong. I am not sure it is related with my software or format.

When I downloaded the data with brandy box (longitude and latitude), I can not input the degree without decimal number. however, my region must cover and larger than the original area I inputted.

I agree with you, my domain selected a little small ,but it is for wind farm analysis, my selection is bigger than wind turbine layout. and when I run the data from my downloaded old time data. which I chose past days period, it runs good and no problem. So I think domain should not be the problem in my case.

by the way, I changed radt =3,3 ,but it still run uncompleted process. (12 hours data calculated 10.40 hours.)

Please view my attachments with my error files. Currently, this error only took place with the data for forecasting. the time after current day.

Thanks for your detail reply.



  • Screenshot from 2021-03-24 10-03-36.png
    Screenshot from 2021-03-24 10-03-36.png
    204.6 KB · Views: 837
  • Screenshot from 2021-03-24 10-03-52.png
    Screenshot from 2021-03-24 10-03-52.png
    189.1 KB · Views: 837
The errors shown in the attachment are CFL errors. These typically occur when the model has become unstable, and usually because the time_step is set too high. Your time_step must be 6xDX or lower. Your DX = 2.7 km, but your time_step = 40, so this is way too large. Try to decrease that to something more like =15 and see if that helps.

Regardless of the fact that your wind farm is smaller than the domain size, we still recommend using a larger domain size. Take a look here for an explanation.
Thank you very much, just back to see your reply and changed accordingly with time_step at 20, it works now.